Carbide Motion - dangerous software bug - Warning to first time users!

Carbide Motion (CM) is pretty easy to use and they’ve done a nice job of making it pretty simple and intuitive but it has one serious flaw for some machines (as of 6/2016) that all new users need to be aware of…

Apparently, this doesn’t happen to everyone’s machine (as of 6/15/16 2pm, 2 of 5 users report it happening on their machines after running the following test)… 6/28/16 correction… it probably does happen to everyone’s machine. I misread one of the responses. Here’s how to test to see if your system suffers from this flaw…

1. Turn on the machine
**2. Open Carbide Motion and connect it to your machine **
3. Jog the machine to make sure its working
4. Turn the SO3 power off for 20 seconds but leave Carbide Motion open
5. Turn the power back on
6. Reconnect Carbide Motion
7. Jog each axis and see if that is the axis that moves
8. Post here to let us know if this is a common problem or an isolated one

If you cut power to your SO3 controller while CM is open it should not allow you to use the software until you restart Carbide Motion. That happens for some. On my machine CM will not recognize that the disconnect occurred. When I turn power back on to the SO3 controller CM will still let me use the machine but it switches the axes so a Y move may ram the Z axis into my part or I might try to jog in the Z axis and ram the bit into my part. If I run a file it will crash the router into something because all the axes are mixed up.

Its easier than you think to switch control power off and then back on without closing out of CM. I did it again today and drove my router through a large piece of acrylic.

Its a really bad flaw since it will ruin parts and bits and possibly cause harm to users. CM should always force a restart (or whatever it needs to do) after control power is cycled to prevent this kind of issue.

You’ve been warned…

There are a couple other controller software packages out but I’m too lazy to switch. Hopefully CM will have this issue fixed by the next update which they don’t announce via an email (why not, I have no idea ???).

What version controller are you on tony?

Argument for why one should use the checklist?

1 Like

I’ve encountered this on multiple occasions and it infuriates me every time it happens. Has happened with every version I’ve ever used, including the most recent build. Is there a technical reason why this bug exists?

Has anyone mentioned it to


Sorry i meant what version of the board

Checklists are good for some things. This is more like having to check that the lug nuts of your wheels are tight every time you drive your car.

Do you think this hasn’t happened to everyone who uses CM? I suppose it could be an issue that only happens with certain computers but I guess that seems unlikely to me. Has it happened to you, @WillAdams?

It has definitely happened to me on multiple occassions. I have sent in a support ticket that was about it in a way. Sometimes I will zero my machine with homing switches and then move the X or Y axis and it will drive through the top of the Z axis and beat the hell out of it. I had to install a emergency switch to punch it out because of it. I have not gotten an answer from support but was asking them how to set the soft limits and what they should be set at because of it.

Hasn’t happened to me, but I don’t get to use my machine much, and I’m scrupulous to follow the checklist.

I’d argue that this is more like not trying to start your car engine when it’s already running.

I havnt had this issue either,Im running the 2.3 version board and cm 257 on asus laptop,If i get a chance this weekend i will cut power to it on purpose and report back.I also had the old board with disconnect issues and was always killing the power and doing diffrent tests to make it cut out on purpose and didnt get the issue you described.Thanks for taking the time to give us all a warning.With any luck mabie we will find a fix or work around

How about it being more like…

You try to start your car with the engine running it reverses the steering wheel without warning. It also reverses the steering when you reengage the cruise control. Now the car takes off at full speed with the steering reversed.

You go to the dealer (after crashing your new car) and the rep hands you a checklist and says, “here you go. … this will fix your problem. Try to be more careful next time”

I think that’s a much more fair analogy :wink:

Or, like learning to drive 3 on a column.

I miss my F150 with three on the tree… :slight_smile:

Not at all. No one would buy another column shift if it reversed the steering if you accidentally turned the key off and on while it was running. That’s a poor analogy.

The fact that Carbide Motion doesn’t allow tool changes is sort of like driving a Flintstones rockmobile (or maybe a column shift) but reversing axes with no safeguard or warning is way beyond that. Its a fatal flaw that is unsafe, poor design for a product that is marketed to the masses.

The question at this point is whether or not I’m experiencing an isolated incident or its common.

It doesn’t happen when I don’t use my machine either :wink:

I see this a lot so I don’t submit support tickets unless it has me shut down.

[quote=“Bonch, post:9, topic:2198”] I have not gotten an answer from support

Anyway, this post is to warn people who might not expect their software to crash their machine. I would encourage everyone to test their machine and post here what you get.

  1. Turn on the machine
  2. Open Carbide Motion and connect it to your machine
  3. Jog the machine to make sure its working
  4. Turn the SO3 power off for 20 seconds but leave Carbide Motion open
  5. Turn the power back on
  6. Reconnect Carbide Motion
  7. Jog each axis and see if that is the axis that moves
  8. Post here if the axis moves the wrong direction or a different axis moves than you tried to move

When I turn my machine off while Carbide motion is on and then turn it back on I can’t use Carbide motion again (non-responsive) until I close the program and start it again. so I guess I’ve tested this on my machine and that is my result.

It’s not uncommon to have to restart software in order to have the hardware be operable again… I have other usb devises that do this.

Your title is misleading and is also very click baity.
suggestion - “Carbide motion bug encountered - reversed axis orientation after hardware restart”

1 Like

I would be fine if that’s what mine did.

You may not feel that way if yours worked the way mine does and you crashed a big job, damaged your machine or cut your finger off because of it. After hearing that its not happening to everyone I’ll adjust it. If I see that it doesn’t happen to most users then I’ll back it off more. For now, I think the safest approach is to make the title as “click baity” as possible.

IMO, C3D should send a warning email to all CM users until this is resolved. Its a safety issue as well as a potentially very costly bug for users.

Thx for posting your test results!

Yeah it’s easy to just tell someone to calm down lol … The amount of profanity I spew when my god damn limit switches trigger for no reason in the middle of a workpiece wasting my time and money!!!.. You are not alone here.

I agree it’s something people should test to see if they have the same error and people should be aware of it. A safety issue indeed. I appreciate you posting about it.

Also please please please EVERYONE keep your hands away from the machine while jogging or running a job, I used to work in a sheet metal part manufacturing plant and watched a fellow employee lop his arm off with a press break… I know the shapeoko belts wont allow that amount of force but still…


Again, please follow the operating checklist and suitable safety precautions — never reach into the machine’s operating envelope when the spindle is running, or the machine is moving.

Does this mean I should stop testing bit speed using my tongue? I sure hope not :wink:

On a serious note, I hope more SO3 owners report here the results of this test.