Carbide Motion Error Message

Help please… I recently had to replace my laptop with a new one running Windows 10 and reinstall software. Just tried to run my first job on my S3 and Carbide Motion returned this error: “GRBL Versions before 1.1 are not supported”. I’m sure it has something to do with the Sparkfun registration code but with so many posts on this subject I am at a loss where to start.
Is there a step-by-step set of instructions someone can offer? Thank you!

Did you download Carbide Motion 4 without updating to Grbl 1.1?

Please try CM3:

I likely did download/install Carbide Motion 4 when I was setting up my new laptop. Now however, using the V3 link you supplied above, it is goes a little further but it is still not working correctly. The S3 no longer does the homing routine on startup and it is instantly waiting for a job to load. It appears to load a job normally, but then does nothing.
Your suggestions please.
Thank you.

Please verify the defaults per: — we have formal articles on this at:

If those things don’t help, let us know at and we’ll do our best to sort this out.

Will, I have checked the settings per your message above and noted some variation (e.g. $11, $12). I have attached 2 screen shots of the settings from my equipment. Not being real proficient with such things, I am concerned about making changes without your direction.
I would appreciate your help, thank you.


Will, I think I have it fixed using the information you supplied. I’ll get back to you if it doesn’t work, but for now, thank you as always!

One more question please. I have an S3 XL, should I upgrade to CM4 / what are the advantages? Thank you!

Carbide Motion 4 is currently in testing, but is working well for most folks who try it. We recommend it for:

  • folks who wish to help with testing
  • folks who have a Probe
  • folks who need Grbl 1.1-specific features such as feed rate override.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.