Carbide Motion not differentiating between two tools?

tl;dr: this is a non-issue that I walked myself through by coming to ask about it. I’m still leaving it just in case it helps someone else. The short story is:

  • tool numbers need to be unique out of Fusion360 to work with Bitsetter
  • trust the screen in CM after loading a file; if it only lists e.g. 2 tools and you think there should be 3, it really does only know about 2 of them!

Just created some toolpaths in Fusion360. In total, I use three tools: rouging with 1/4 flat, and finishing with a 1/8in flat and 1/8in ball. Here’s the tools in use for this project:

I exported them all, and you can see the full list:

I brought these into CM (build 564), and saw this:
image

I thought, “meh, this is probably a nuance/fluke and it surely knows about the third tool.” Turns out this was false! It ran my contour passes happily with the 1/4 flat end mill, never prompting for a tool change until the parallel path with the 1/8 ball.

I don’t see where one specifies tool numbers in Fusion360, but either way… shouldn’t CM know by the diameters that these are different, even if the indices are redundant?

Ok, well as usual with most bug reports, by the time I summarize it and double check/walk myself through it… I find something new. I just noticed there is, indeed, a renumbering option in Fusion360 where I was able to select all the tools in this program, click the button, and get them re-numbered.
image

This is probably due to my newness to the Bitsetter, which I just set up less than a month ago. I’ve never had to care about tool numbers before. And of course now that I’ve had that thought… looks like I didn’t RTFM, getting all excited to use it after the installation part :slight_smile:

In order to instantiate a tool change and offset measurement, your CAM program must post unique
tool numbers with each new tool. Carbide Create does this by default.

Since this is all written, I’ll post it anyway just in case it helps leave breadcrumbs for someone else searching for this issue.

3 Likes