Carbide Motion Release 351 - File load errors

So i have just downloaded the latest release (Build 351), and i suddenly cannot seem to load any NC files into the program.

The error popup says “Error in line 12: Syntax Error G1A0.0000Z-0.0250F5.0”

I am running the MAC OSX version if this helps.

These are all nc files i have previously used, I have even tried loading the file to no avail. Has anyone else downloaded the latest build and had any similar issues?

Thanks :slight_smile:

I am getting the same error. Just updated to the latest version and all of my NC files can’t be loaded into Carbide Motion. I am on Windows. What’s going on?

Error in line 12: Syntax Error G1A0.0000Z-0.0250F5.0

I’ve never understood the A0 in the post processor. Since the Nomad is 3 axis, the rotation around X (A) is unnecessary. C3D should remove it - unless they explain that there is some magic thing we don’t know about.

Could you try this:

A) Use “Show package contents” on CM.
B) Open Contents. Open Resources. Open Posts.
C) Double click on Carbide3D-Inch.con.
D) Remove the “[R]” from from the two FEED_RATE entries.
E) Save.

You should uncomment the ARC commands too.

Now try to generate a new tool path and load it with CM.

Try editing the “.nc” files and removing any “A0.0000” via a global remove.


Here’s the response that I got from Carbide 3D:

Hi Derek,
The latest update to Carbide Motion doesn’t accept A commands. You can try re-downloading the latest version of the wrench tutorial, which was just updated.
In the mean time you can use Carbide Motion v2.


Jorge Sanchez

I had a feeling it was the “A”! :innocent:

Follow my directions and that will fix your MeshCAM.