Carbide Motion Startup Error

Before Christmas, I purchased a NuVision tablet that runs Windows 10 64-bit, hoping to use it to drive my Shapeoko 3XL. I was able to download and install Carbide Motion V3 build 366, but when I try to start the program, I get this Application Error:

“The application was unable to start correctly (0x0000007b). Click OK to close the application.”

I was hoping there might be a Windows guru out there who might be able to help me get past this error.

I would uninstall it and try a new download and install it again.If that dosent fix it, try google there was tons for (windows 10 error The application was unable to start correctly (0x0000007b)" and look for the tom’s hardware guide,they are really good.Hope this helps!


I have already uninstalled and re-downloaded and re-installed several times. I’ll look for the “Tom’s hardware guide” as you suggest.



Thank you for pointing me in that direction. A video from “Tom’s Hardware” helped me find the fix! I had already downloaded and installed the 2013 Visual C++ distribution for Windows 64 bit, but the video said to get the one for 32 bit as well. I installed them both and the program now starts up! I’ll just have to see if I can get it connected now and verify it works!

Thanks again!


Thats Awesome Greg,Post back if any other issues come up,ill check back in soon :slight_smile:

Does anyone have any other suggestionsfor solving this problem? I tried all of these things mentioned above and Nothing works. I can’t get the program to open without 4 missing .dll alerts popping up, I have literally tried everything I can find in this forum. It’s been hours now and I’m going crazy.

Which version of Carbide Motion are you attempting to run?

Please see:

(despite the name/URL it also has links and information on the current 140 DLL situation as well)

If that doesn’t help, let us know at and we will do our best to assist.

Hello, just wanted to post an update on the final outcome of my mini saga. After much frustration, and a lot of fiddling, I ended up UNinstalling all of the various Visual C++ Redistributals I had installed and then downloaded them again and installed one right after the other. The 2013 x32 and x64 as well as the 2015-2019 x86 and x64. After this, voila! , I was finally able to open Carbide Motion without any error messages and proceed to connecting it to my Nomad.
I might have overdone it by installing all 4, but it’s what worked for me in the end and I’m done fiddling with it.
Thank you!