Carbide Motion - stops partway through surfacing job

I’m running Carbide Motion 513 on Mac OS (10.14.6). Brand new S3, clean install of Motion and Create.

It’s mostly been fine, but when it came time to surface my waste board (one big pocket at 0.010" depth), the job stopped halfway through. Gantry was stopped, but bit was spinning. I couldn’t pause and restart, manually ! and ~, and Motion was otherwise unresponsive. The only way to recover was to kill power to the controller and reboot. I tried again, and it got a little further but stopped again. I checked the g-code and everything looked fine (generated by Carbide Create). It was around 720 lines before I started trimming it down for subsequent iterations. Eventually I got my waste board surfaced, but it took a few iterations. If this happened on a job where my cutter was more than 10 mils deep, the friction could have become a fire hazard.

Has anyone seen this behavior before? Any ideas what might have caused it?

I tried opening the log window after the fact, but apparently it doesn’t log anything if the window isn’t already open. Is there a persistent log file somewhere that I can dig up? If the GRBL controller had an issue, it should’ve reported it to the g-code sender.

Thanks for your thoughts.

Usually this is EMI. Contact support@carbide3d.com for a 10 step plan or see:

https://wiki.shapeoko.com/index.php/Electronics#Recommendations

Thanks, Will. I rearranged my bench so the router’s power cable is no longer passing over/beside my USB cable. Laptop is now on the opposite side of the Shapeoko. With any luck, that’ll be enough… otherwise I’ll dive into the EMI rabbit hole.

2 Likes