Carbide Motion Update

After the new update of Carbide Motion today I have lost all control of my S3. The window will open and it will connect to the cutter, then all I get is Not Responding at the top of the window. Anyone else having problems with the update.

Thanks, T

I have been testing the new CM update and had no problems, please email with your computer details.

I noticed the fast and slow jogging lost their smooth jogging after the update.

Which machine are you using?

I am using S3 also the jogging looks like faster

Same for me (S3), so I have jumped backward to Ver 349. I was also losing connection every 15 min on average for no apparent reason (Almost never on the old ver)

S3 user, I did the update yesterday and today I am having issues with running any jobs small or large. It will stop without reason anywhere in the job. Sometimes it will get 20% other times it’s 80%. Thought it was a noise issue as I have just moved my shop to a new location. So I have run the typical gamut of troubleshooting with no luck, running a job without the router or dust collection running and it just up and stops with no reason why. Rolling back tomorrow to the older version firmware.

1 Like

Just ran a small slotting experiment with the latest CC/CM tandem. Maybe a 5 minute job, but I ran it twice and there were no issues using with my S3XXL.

When you dropped the connection, what error did you get?

The latest version of CM is very aggressive in throwing an error if GRBL misses a status update. We can alway relax that requirement, but I’d be like to be sure we know why that’s the problem (if it is).

There may be a case where status updates get delayed that we didn’t consider beforehand but we tested that release thoroughly and didn’t get any errors in house.

My jogging is no longer smooth on the s3 either after the update


Problem 1
I get two errors. The first is that CarbideMotion (Ver.360) stops working (Not Responding) and locks the system, and I can’t clear it even with the task manager. The second is a pop up window that says (I didn’t write it down, and hopefully other users wrote it down).

Problem 2
I can’t enter my Work Offsets (Ref: G10L20P1X0Y0Z0), P2, P3, etc. I get: MDI Error: Unsupported G Code. This is important because I often have 2 set up on the machine (e.g. Vise G55, and present job G54).

Problem 3
Jogging is very jumpy, no longer smooth (Fast OR Slow), almost like it moving 1mm at a time.
I hope this helps (a little)

System: Window’s 7.1 Tablet, running Win8.1 with full size USB 2.0, (Up to date on on the MS updates)

NOTE (Update): After seeing Apollo’s comment about the small update to 360, I upgraded from 349 TO 360.

Same here, I even tried to go back to the previous version with no luck. Still the same problem.

  1. Getting a lot of disconnect errors.

  2. Jogging has got very jumpy, it never was really smooth anyhow but now it is almost unusable.

  3. When I an running a simple program, say cutting a 2" circle. It no longer cuts smooth all the way around. Now it stops about halfway through the job then starts again.

Nothing else on my computer has changed.

Running Windows 7 Pro (all updates installed)

VCarve Pro 8.5

Shapeoko 3

Once again, everything was running perfect until the Carbide Motion Update.

Just an update, I tried rolling back firmware and couldn’t find the last build only older version V2 which wasn’t installed on my machine.

Still having an issues with the current build version. I did however run an older file that I had built using the last build version of CC and didn’t have any disconnection issues.

Could it be an issue with building files in CC and CM having a problem executing the file? I’m throwing spaghetti at the wall here as I have NO coding knowledge what’s so ever. I had also forgot to mention that I had updated both programs the same day.

I hope there is an answer soon!


I FOUND THE ORIGINAL ERROR: (That I was getting every 10-15 min. last week)

GRBL Error: Serial Port: Device Not Found Error

PS Note the the guys who had trouble rolling back: I rolled back to Ver 349, and everything went back to normal (Including the Fast/Slow Rapid, G10L20P1X0Y0Z00

I still get Disconnects but not nearly as ofter, and if I don’t run anything that has a motor, the disconnects are quite rare (on Ver 349).

Ok I rolled back to V2 350 and still have the same issue, Can someone please run this file just to verify and see how far they can get? It’s a simple 8 - 3mm x 5.5mm deep holes. Im lucky to get to 30% into the job before it quits.

EDIT: One other thing worth mentioning that I just noticed is when this particular file is running the first few seconds is the tool path starts to run slower and slower befor it quits all together if that helps.

5x4.5 mag holes 2.egc (95.4 KB)


The only change to the recent CM is to check connectivity more often.
Are you running Carbide Motion in the background
I ran the job twice, no problems
Im on a 5 year old Mac Book Pro.

Thanks for running the file Apollo, CC CM are the only programs running and the iMac is a vintage 2009 which has been running fine since I started using it with the S3 at the end of last year. Could it be a USB cable? I mean I have not changed anything on the two machines sense I have started using them.

It could be the cable or the port.

I know how to check the cable, is there a way to verify the port and how do I go about doing that?

Changed out the cable and checked all 3 USB ports still have the same problem. I opened up the code screen and took a screenshot of the last code after it quit… I also noticed if I cleared the code in the screen it would keep going until it slowed and stopped again.