Carbide Motion updating and Raspberry PI

I have been running Carbide Motion build 550 on a Raspberry Pi very successfully for over a year. It is connected to my Shapeoko 4 which I am equally happy with. The marriage of the two is brilliant. I am attempting to update Carbide Motion to latest build on my Raspberry but am having no success. I thought I could download the new version, then run it and it would just update the 550 build. It did not. I clicked on the icon for the new version but when it opens CM the 550 build shows up. Hmmmm.
I tried to remove 550 build but it says I have no permission. I then went into the properties for the CM 550 file and made sure the permissions were set that “anyone” has permission. Tried to remove it and still got message I have no permission to do so.

Thought process is…remove old version of CM and install new version… then go on my merry way. Does anyone have experience with using Raspberry Pi as the platform to run CM for a Shapeoko CNC.

Appreciate any help.

The RasPi people instituted security measures, And requires passwords and secret handshakes now to update anything. I was a the point of reinstalling the whole operating system until I tried one last password.

what do you mean about secret handshakes…how did you resolve them?

Secret handshake was meant as sarcastic humor. But to resolve the install, I had to sign into the Pi with the user name and password that I had to provide when I first set it up,

1 Like


For those of you who run Carbide Motion on a Raspberry PI to control your Shapeoko, if you desire to update your CM version it is much easier then I thought…particularly once I found the attached link. When on your Raspberry Pi, go to your browser and go to this link:

Download it, Run it it…enter your password and you are good to go. It automatically updates your previous version.
Hope this helps someone…


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.