Carbide Motion will not connect to my Shapeoko 3XL

Hi All,

I have a Microsoft Surface Pro, running Windows 10, that I can not get to connect to my machine through Carbide Motion. When I install Carbide Motion it gets to the Device Driver Installation Wizard, when I select next it immediately tells me that the Drivers were successfully installed and should be working. It does not appear to be actually installing any drivers. I know this because I brought my Alienware laptop out to the shop, installed Carbide Motion and when I went through that process it clearly went through an install process during the device driver installation. That computer connected to the machine fine and I was able to run “Hello World”. I have searched through the community and found some old topics where it talked about un-signed drivers. Knowing that these drivers are signed I tried the solutions to those issues anyway with no luck. I really want to use the Surface Pro in the shop. My Alienware is a beast and would rather not have to disconnect from my desk setup each time I head to my shop. It’s either that or I buy a new computer. Which I am always willing to do, but want to exhaust all other options first.

Thanks in advance for any help you can give.

Folks have used Surfaces successfully — what does your Device Manager show for the port when the Surface is connected?

Will beat me to it
You may want to check
- if when your turn on the Shapeoko, you see a serial port showing up in Windows’ Device Manager ? If not, definitely a driver issue.

  • if you do see a serial port, you could try a different G-code sender just to see if the issue is specific to CM (download, execute and try “Connect” in the “Connection” section)
2 Likes

Device Manager shows nothing. The Surface does not even recognize when I plug the USB cable in. I have tried many other USB devices and they all work fine.

In that case, it would seem to be an issue with running the installation of the drivers — is your Surface fully patched/up-to-date? (I’m hanging back at 1703 on my stylus machine, a Samsung Galaxy Book 12 'cause I can’t stand how MS crippled styluses in Fall Creators Update).

Have you tried:

  • making a new admin account
  • cold reboot
  • installing the app in the new admin account

?

Here is some instructions from MS support. might help.
Method 1: Run the Troubleshoot Hardware and Devices.
Hardware troubleshooter reviews, diagnose and identifies operational or technical problems within a hardware device.

  1. Press Windows Key +R , type Control Panel .
  2. Type troubleshooting in the search bar, click on troubleshooting.
  3. Click on Hardware and Devices.
  4. Follow the steps from the wizard to run the troubleshooter.

Method 2: Uninstall and re-install USB drivers:

a. Press Windows Key +R and type devmgmt.msc to open Device manager.
b. Expand Universal Serial Bus controllers at the left bottom.

c. Right-click the first USB controller under Universal Serial Bus controllers, and then click on Uninstall to remove it. d. Repeat these steps for the entire USB controller under Universal Serial Bus controllers.
e. Restart the computer. After the computer starts, Windows will automatically scan for hardware changes and reinstall all the USB controllers that you uninstalled.

Refer the article for more information:

http://windows.microsoft.com/en-US/windows-8/install-usb-3-usb-devices

1 Like

My surface is fully up to date. I tried making a new admin account. Same results, it just doesn’t appear to be loading the drivers.

Neither of these two methods worked. Still no contact with machine.

Sorry those did not work. Have you tried installing a different version of CM? I had a problem installing CM on win7 and had to install a different version of CM.

Maybe someone using a Surface successfully can reply and compare settings and driver versions and files. Or you can try contacting MS support.

1 Like

David thanks for your reply. I made the decision to purchase a new work computer, so my old work computer will function as my CNC computer. After all one can never have too many computers. I already have that one working and connected to the shapeoko. I appreciate the help from the community.

1 Like

I gotcha. I would have loved to have a laptop or tablet for my cnc but I had a perfectly good old pc sitting in the corner so $15 worth of memory and I am up and running. I have been in the software/hardware business for 30+ years and this kind of stuff just aggravates the stew out of me. Typical of Microsoft. You would think after 20 years, they would have perfected plug and play. Rarely have these problems with Apple at least in my experience albeit limited. Glad you solved your problem sort of. On the bright gave you a “reason” to get a new computer!

1 Like

You never have enough computers until one fails and it is not backed up. The trouble with multiple computers is remembering to back them up. I used to fix Apple computers and you do not know how many times I had to replace a hard drive and the customer looked at me and asked what about my data. I would reply I have restored the operating system now you pull your back up out and restore your data. I just got blank stares. You need to have a way to restore the operating system and then restore your data. If you do not have these two things in place you will be crying one of these days. Back up often and multiple places if at all possible. Personally I do not have the bandwidth to back online (wish I could) so I back up on to two different USB drives. I also made the operating system restoration disks when my computer was new. You can buy an operating system restoration USB on ebay and other places but you need your license keys saved. Many new computers have the license key stuck somewhere on it but if it is not there you need to record the number yourself.

1 Like

Totally agree on the backup. I have a NAS (Network Accessed Storage) that I keep all my data backed up on. So I have what amounts to two copies there plus the one on my computer. If all three drives fail at the same time, I quit! Operating system restoration I am not so good at, but I only buy Dell/Alienware computers and they have the license key label on the bottom so that works for me well. Still waiting for my new Alienware to show up, they screwed up my first order, so they had to cancel that order and re order it. Something about a software glitch on Black Friday. So I am waiting still.

1 Like

Well since we are on the topic I have to tell this story that happened about 2 months ago. My wife’s boss has an IMac at home. The sector that stored his password apparently got corrupted and he was locked out. I bought a new drive for him, downloaded and installed IOS from Apple site with just a formatted drive (try that MS!) Once I got the IOS updated to his version, I connected the old drive as an external drive. To my surprise, the Mac recognized it as a Mac drive from another computer, asked me if I wanted to recover from it. I said yes and about an hour or two later the mac was like it was when I got it. ALL his data, years of pictures user accounts. etc just like he left it!!! One or two of his MS apps had to be updated but unless MS has added this type of capability in win10, you could only come close to this seamless restore on a PC unless you had a complete image backup. This is why you pay such a premium for Apple products!! I was amazed and the boss also amazed. He was just hoping he could get his photos back.

2 Likes