Carbide Motion Won't Jog Manually to Surface

I had to reinstall Carbide Motion on a new laptop (build 564), and had to reconfigure CM. I have a Shapeoko XL with a BitZero (I selected BitZero v1), and an HDZ for the Z drive. I notice that when I’m jogging to the surface of my material, the spindle gets to a point where it’s approx. 4mm above the material and it stops jogging down (I was trying to sanity check the BitZero with the traditional paper method). When I load a gcode file produced from VCarve, the following is shown. I set the toolpath so that the material depth is .3125 and the cut depth is .340 so the depth reported below is correct. The other issue is with this same gcode file, that does cut correctly, I ran it once and the spindle moved to an upper right location far from the material and started cutting into my hold-downs. So there are two issues. Does anyone have any ideas? One item of note: my new Dell XPS has all USB-C ports, so I’ve a uni USB adapter for the Shapeoko XL controller interface. Thank you.

Program Size

  • Width (X): 293.03mm
  • Depth (Y): 22.23mm
  • Height (Z): 21.34mm

Cutting depth below program zero -8.64mm

Approximate Cutting Time: 10 minutes

What is the Travel Dimension for Z set to?

How are you positioning the BitZero and probing?

Usually such difficulties are from a disconnect in how you are setting up the file and how you are setting up the machine.

Post the .c2d file, generated G-code, step-by-step notes on how you are securing your stock and setting zero relative to it and managing all tool changes and a photo showing an attempt at cutting still in place on the machine.

What is the Travel Dimension for Z set to?

95mm

How are you positioning the BitZero and probing?

Material surface, with the bit manually jogged to within ~10mm of the BitZero top, then selecting Probe/Z. It does probe correctly.

In Vcarve, there’s an X/Y Datum Position offset. The checkbox “Use Offset” was selected. I changed that to disabled, regenerated the toolpaths and saved the gcode. This time it didn’t shift up to the upper right of the material, and cut correctly. Material secured the way I’ve done it for two years with the Shapeoko; with blue painters tape on the material and spoilboard, cyanoacrylate on the blue tape that’s on the spoilboard, and accelerator on the blue tape that’s on the material (it never gives way during cuts). But, I still cannot jog Z down to the material surface. I’ll keep an eye on these cuts to see if it attempts to start in the upper right past the material again. Thanks for your response.

Setting a datum has often been a problem for folks using Vectric software.

Three iterations of the cut and so far no issue. But, I still can’t manually jog past 4mm above the material surface.

Try increasing Z-axis travel dimension to 100mm