Carbide motion won't remember my machine as an xxl

Every time I open carbide motion I have to go to settings and tell it that this is the xxl. How do I get the program to remember that? What am I doing wrong?

The table size should be set in Grbl — does it fall short when doing a rapid position?

Everything works fine as long I remember to go into setting and tell carbide motion my machine is the xxl. But I have to tell it that every time I open carbide motion.

To elaborate:

  • if you power up and connect to the machine
  • home the machine as you normally would
  • then do a rapid position

Does the machine fall short or does it travel to where it ought to?


  • are you using Grbl 0.9 or 1.1?
  • Carbide Motion 3 or 4?

It will travel to the right locations after I select the xxl option on the setting page I’m using grbl 1.1 I’m assuming carbide motion 4 I’d have to double check when I get home. I just got the machine brand new last week. After I use it and exit carbide motion then open it back up it’s back to saying shapeoko 3 in setting instead of xxl

I have to select the xxl in settings before I home it or it will think it’s the shapeoko 3 and the rapid positions will be off

1 Like

Out of curiosity, after you selected Shapeoko XXL from the dropdown menu on the settings page, you did click the “SEND CONFIG DATA” button and the “Open Log” link to watch things go, yes?

(The procedure is shown on the “Enable Homing in Carbide Motion” document, for reference.)

Yes I did seems to be doing what it’s supposed to but it will not remember my machine. It’s not a huge deal just annoying to have to remember to change it to xxl before every time I use it.

I suspect that’s a permissions problem for Carbide Motion saving its settings.

Are you using Grbl 1.1 and CM4, or Grbl 0.9 and CM3?

Yes I’m using 1.1 and cm4

Mine does the same thing, but but I think thats just the default text for the option box. It’s actually saved into grbl on the machine and carbide motion just defaults showing shapeoko 3. Does that make any sense lol?


Lol ok but do you still have to change it every time you use it because if I don’t that work area becomes the size of the shapeoko 3 not the xxl.

No need to change to xxl upon startup, your machine remembers.

I remember this issue when I converted mine to an XL.

No worries


Ok great I’ll try it tomorrow thank you!

You got it Griff. I scratched my head when I first noticed it, then I shut down machine and when I reconnected everything it said Shapeoko 3 but all limits were confirmed to be XXL.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.