Carbide Motion z axis problem?

Had my xl machine for several weeks now and haven’t had this problem, but think it is either something in Carbide Motion or in the machine itself.
I used Vcarve software to create a very simple job so I could test the results I get using seven different router bits. I simply wrote seven lines of text, each line only had around 10 letters. I created a different profile for each line of text using a different bit, and saved the code of each one separately.
I loaded the first gcode into Carbide Motion, went thru homing, set the x,y,z axis all to zero at lower left corner, and ran the job. The machine went to correct position on material but it was cutting the letters in the air because the bit was staying about 1/8 inch above the wood.
I tried some of the other gcodes and they all did the same.
I tried creating a whole new job with only one line of text and one profile, and it did the same.
i then tried creating the program with Carbide Create, and got the same results.
This makes me think the problem is in Carbide Motion or the machine itself.
Funny thing is, I ran a program I had created earlier for making a sign, and it worked perfectly.

Any ideas on what is going on here?

Thanks, Lewis

There are a couple of different places to set Z-height:

  • in the CAM stock setup origin selection
  • when you set zero on the machine
  • whether or no the zero is set to the top of the stock, or the surface of the wasteboard

They all have to agree, and it just takes a little disagreement to get things way off — I try to make a note of where the stock surface is set in the G-code filename.

I do it the same each time…In the CAD program I set lower left corner and top of stock as zero. In Carbide motion I home the machine, set to zero, and then jog x and y to lower left corner and then lower bit until it just barely touches stock. I then set all to zero. This has always worked until today.
When I run the program it goes thru the motions of carving the letters, but bit stays about 1/8 inch above stock.
The job created several days ago runs OK, but any jobs I program and run today all fail. That seems to indicate that Carbide Motion is working and something is set wrong in CAD, but I tried using both Carbide Create and VectricVcarve, and both give the same results.

Also, when I view the simulation in Vcarve, it looks perfect.

upload the file if you want,mabie we can see what going on.Also is your stock sitting lower today than any other day you have had success?

I’m not sure why stock hight would matter as long as I zero z axis at the lower left top surface of the wood.

isnt there a soft limits set to 80mm of travel,no idea if ur below that or not with the stock

The stock height and zero point are both very important.

When I started designing I set the zero in the bottom left corner, but set my Z zero as the bottom of the stock. The machine quickly plunged right through my stock as it assumed the zero point was far below where it should have been. This can happen the other way around if the stock height is not set correctly.

Now when I set my zero position I always check it’s onto of the stock as below:

I suspect you have set your zero position button correctly but you have a stock off-set of say 1/8" which is causing it to draw in the air.

1 Like

Might be worth trying a different communication / control program — that might identify this as a bug in Carbide Motion (note that there is at least one where origin doesn’t stick and one has to go in and out of the jog pane to verify and ensure it has been set).

I find it helpful to use the machine operating checklist:

and try to keep a logbook.

The problem is, CNC is a bunch of repetitive things each of which depends on all steps before having been done to a setting which is the basis for future actions — any disconnect causes things to be wrong for the balance of the task.

OK, I am completely at a loss to explain what was wrong.

I spent all day yesterday trying to get a simple job to run and never could get it done. I wrote and re-wrote the jobs using Vcarve software and Carbide Create, and both gave the same results, the router bit stayed 1/8 inch above the wood.

I went thru both programs and double checked that I had x/y zero at top of lower left, and I set z zero so that bit was barely touching the wood. Nothing worked.

Today i went to my shop and decided I would run one of the jobs again, and guess what, it worked perfect, and everying has worked all day long.

I know I was setting everything up yesterday exactly as I always do, and exactly as I did today, so I have no idea what the problem was.


1 Like

I had a similar problem. I discovered that I had set my tool clearance to high, so that when the tool moved to the start location it would retract to high on the z and skip steps. I corrected this and all is well.

I do have limit/homing switches, but do not have soft or hard limits turned on.


May not at all be related to your problem, but I’ve noticed big temperature changes in the shop can affect the belts.
I was running a long job last week-

and noticed a change in depth after about 5-10 minutes of running.
I’m pretty sure I didn’t loose steps, because it’s usually a pretty noticeable click.
But it was early and cold outside.
After that it didn’t change the rest of the day. Plus the machine is new with new belts. I’m thinking being brand new it might have a little stretching and breaking in to do, plus the temps going up and down would affect things a little. Not an 1/8" tho.