Carbide VFD Not Respecting RPM

Hey folks,

I’ve had my Shapeoko 5 Pro up and running for a few weeks now. I swapped from the carbide compact router to the carbide VFD, but I’m having some issues.

Regardless of what RPM I have set for a given tool, the VFD always spins up to 24K RPM. Im new to the CNC world but not to software and hardware troubleshooting, so I’ve tried a number of things with no result.

What I’ve tried:

  • ensure post processor is set to Shapeoko
  • manually send commands /m3s10000 (for instance) and the VFD spindle raised the rpm to about 9400 rpm (not quite the 10K I requested from it)
  • reinstalled carbide motion to ensure my config was correct

One odd thing I noticed in the config section of carbide motion is that the setting for bitteunnerenabled = true

Before I installed the VFD, I did indeed have a BitRunner installed. I’ve re-setup the machine and ensured BitRunner was not checked and VFD spindle was, but it seems like those configs are either not being respected or applied perhaps.

Anyone else have experience with this and have suggestions of things I can try?

I just got off a support call with (shoutout) Fleming and solved the issue.

As I suspected, it was related to that bitRunnerEnabled = true flag in the machine settings. The fix is pretty simple.

  1. Connect to the machine with carbide motion
  2. Click on the build number at the bottom left of the screen
  3. Click on “open configs” (or something similar to this, can’t recall exactly). This will open up a folder where the machine’s config .json file is located
  4. Delete the shapeoko config .json
  5. Close carbide motion, disconnect USB, reconnect, then relaunch carbide motion
  6. Set up the machine as normal, making sure VFD spindle is selected and bitrunner is off
  7. Profit

I’m not sure how the firmware on these machines is setup, but it may be possible to shortcut that process and just modify the .json file and set the bitrunnerenabled bit to false manually if writing to that directory is enabled, which it seems to be.

Additionally, there is a ~10% variance in VFD speeds. This makes sense, since my controller is displaying around ~4.6V and I’m getting around 9400 RPM when asking for 10K. This is normal, and if speeds are important to your milling operation, experiment to get them to the exact RPM you require rather than assuming the RPM entered in the software is what you’ll get.


I dont have the C3D VFD/Spindle but I believe I have read here on the forum that the C3D spindle is about 10% off from what CC calls for. I think it is a firmware issue with the VFD/Spindle. Hopefully C3D will get that corrected at some point.

Yeah agreed. Thanks for the info! Glad things were WAI just not WAE.

Man, I’m getting old. :upside_down_face:

1 Like

Haha sorry. Working as intended, not working as expected.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.