CC V7 trying to conver to .stl with Extract Gcode. Not working right

I am trying out V7.I have the post processor set to “basic Gcode in Metric” When I use extract GCode to convert the file to .stl, the file is not formatting correctly. What my issue is, the file measures a 10 inch perimeter circle. I created the file in CC in inches ( cuz I don’t know how to set it to use mm instead of inches in the design window). When I load it into my cnc, it starts milling the circle at about 10mm circle (approximately). Way too tiny!

Why is it doing this and how can I fix it. Thank you for your help

without any geometry selected the gear/cog will be visibile under setup.

bottom Units field is used to switch between metric and imperial, maybe give that a try


Thank you Stephan. I found it. That worked but found another issue. Don’t know if I should start a different topic but when milling this model, it requires 2 bits. When using the extract GCode website to create the .stl file, my CNC stops for about a second at the time I am supposed to change the bit then starts back up and continues on without the bit change.

Is there a work around or a way to stop the process and pause the job until the bit is changed and I tell the machine to continue? I did not have this issue with V6. That version worked as it should.

Thank you again for your help

What post-processor do you have selected?

“basic Gcode in Metric”

You need to use “Carbide 3D Shapeoko” or “Carbide 3D Nomad” for tool changes.

I have a generic home built CNC using Mach 3. Will Carbide 3D Shapeoko” or “Carbide 3D Nomad still work with that?

No I think @WillAdams assumed you had a Shapeoko/Nomad. The generic or GBRL should work for a 3rd party machine. The Shapeoko/Nomad post processor allows the BitSetter to function. If you do not have a Bitsetter on your machine the Shapeoko/Nomad would not work.

1 Like

ok… Thank you for that info Guy

The “Extract G-Code” site should output/download a .nc file (G-Code).
(.stl files are 3D models. Not pertinent in this discussion.)

The difference between the Basic & Shapeoko posts is the tool change. (And some comments that CM uses.)


M05                   (Stop the spindle)
M0 ;T102           (M0 is Stop. Pauses to let you change the tool)
M03S10000       (Start the spindle at 10000 RPM)


(Move to safe Z to avoid workholding)
(Toolpath: Contour Toolpath 1)
M05                          (Stop the spindle)
(TOOL/MILL,0.125, 0.000, 0.000, 0.00)
M6T102                 (M6 is toolchange, T is tool number)
M03S10000           (Start the spindle)

On a Shapeoko machine using Carbide Motion as a controller, CM interprets M6 as
Move to the toolchange position
Stop & prompt for tool (Uses T102 to formulate the toolchange message.)
Continue to bitsetter if enabled, measure tool, return to toolchange position
Pause. Continue on “Start”

M0 on your Mach3 controller should Stop, and wait for you to hit Start.
If you can read the current line being executed, you’ll also see the comment, ;T102
which should let you know which tool to load.

Mach3 can be configured to support M6 as well. It looks like it may need to be turned on in (Configure>Logic) ( 10.8.3 Tool change - M6)

It looks like the “Extract G-Code” website only outputs the Shapeoko posted code, regardless of which post you have selected in CC.
So you either need to edit your files and change “M6T102” to “M0 ;T102”, or configure Mach3 to work with the M6 command.

1 Like

Thank you Todd. Your explanation is VERY helpful. In my issue, the machine pauses for about a second, it does NOT wait until start is pressed, then starts back up and continues on. I will check my configuration for the M6 command.

Thank you again

Check your configurations,

1 Like

Thank you Steve. I’ll check that today.

This topic was automatically closed after 30 days. New replies are no longer allowed.