CM 407 Gets Messed Up After Pause/Stop

I’m having an issue where after I stop a job, the next time I rapid to my last XY offset the spindle races diagonally INTO my workpiece from home. I usually have to close CM and reopen it to guarantee it doesn’t happen. I wasn’t fast enough to catch it today and it ruined a piece. I’m using the Nomad with CM 407.

Also had an instance where it caused incorrect homing, such that when the machine went to probe tool length, it was about 5 mm off, and the bit MISSED the probe. Ended up registering against the collet nut, instead of punching the endmill through the floor of the machine.

Probably an instance of the machine/software getting confused about relative/absolute coordinate system, but this is pretty bad… Also if anyone can confirm the behaviour so I know I’m not crazy, that’d be great. Run some gcode, stop the program halfway through, then try jogging again.

Isn’t v4.08 the latest release?

It’s technically the latest, but AFAIK there’s no public link. 407’s what they still link to in the GRBL 1.1 update page.

I have 408 on a different machine, but I assumed the only things added were for the touch probe.

tech support question 1: “what version are you running”? not that it makes any difference with your issue.

Moving from home to job zero sounds like it’s “by design” and basically mirrors the movement on the opposite end of a job (quitting mid-job in CM).

Not sure about your probe zero anomaly. Don’t you jog to the approximate spec’d position the probe expects for your tool then let it go? Sounds like a major hiccup.

While I would so appreciate a touch probe in the CM workflow, it’s other shortcomings have kept me holding off from upgrading… v3 for me for now.

1 Like

Moving from home to zero is supposed to be controlled. There’s TWO buttons, one for X-Y, and one for Z offset in the rapid positions option. Hitting the “XY” button that’s supposed to move OVER my desired zero but NOT move the Z axis, ends up moving the Z axis. Which is not what happens in any other condition.

Nomad tool length probe is not handled like touch probing on the Shapeoko. It’s completely transparent. Machine automatically moves to the correct coordinates to probe, which is fixed. Only way it will probe in the wrong place is if its coordinate/movement system gets messed up.

“Hitting the “XY” button that’s supposed to move OVER my desired zero but NOT move the Z axis, ends up moving the Z axis”

I’d say that’s a whoops? Is it moving to the retract height?

Nomad tool length probe…

Say no more, of course your “other machine is a Nomad”