CNC Control Nightmare - Please Help

Ok, so I’m new to CNC. I purchased a Nomad 883 back in May and it arrived in mid June right before I was leaving for a 1 week trip. I unboxed it, and found it a nice home on it’s own desk in my office. While traveling, I got all of the software loaded onto my machine so that I would be ready to go when I returned. I even got started on a few projects in Fusion 360. When I returned home, I was so excited to make my first project. I started with the wrench project that is part of the Nomad new users tutorials. I had no problem loading and running the files, but the double sided sticky tape did not hold and the cut was unsuccessful. The second time I tried it, the material stuck down good…too good. The wrench bent when removing it from the table. Not a perfect start, but not bad either. I wasn’t interested in the wooden sign or the 3D figure, so on to my projects.

I designed a awards medal in Fusion 360 with plans of cutting it out of 1/8" aluminum plate. After completing the CAM setup and configuration, I i exported the .nc file using the Post Processor function in Fusion 360 using the carbide3d.cps config option. The file is quite large at 160K lines of G-code.

I loaded the file in Carbide Motion, set the out the zero point of the material stock and started the cutting. About 30 minutes into the process, the Nomad 883 stopped cutting (spindle was still rotating) and the following error was displayed in Carbide Motion, GRBL Error: Invalid gcode ID:33

I paused the job and tried to continue with no luck. I restarted the job and ran it again with the same result. The error happens about 30 minutes into the job or about 12% through according to Carbide Motion. After reading the forums and changing parameters in Fusion 360 and doing a new .nc Post Process, I continue to have the same issue. I can’t seem to identify what the issue is.

After hours and hours of no luck, I decided to give bCNC a try. It was a little cumbersome to get installed and working, but I have it connected to my machine and I can jog the mill and turn on and off the spindle. I just cant seem to get it to run the g-code file. The file loads fine, and displays properly on the preview screen. It just wont execute the g-code. When I hit play, the Nomad 883 jog’s a few mm and then stops. The spindle never starts, and the tool length is never checked. I’m certain that I don’t have some of the configuration settings right for the 883, but I can’t seen to find out any details on the step by step setup of bCNC for the Nomad.

I eventually want to get bCNC on a Raspberry Pi 3, but for now, I just want to get the thing working from my PC. I’m stumped and don’t know where to turn next. I didn’t want this to be my first post in the forums, but I’m out of options. The wife is questioning why I spent the money on this thing, if I can’t even get it to work. I need some help fellow Nomad users.


PS - Here is the .nc file that I am trying to run if anyone is interested.

ODO Medal Final (902.4 KB)

Hi, I am running the gcode right now. I just installed the latest version of Carbide Motion on an older MacBookPro. I have a Nomad Pro. I’ll see if I can repeat your issue.

1 Like

Thanks Jerry. Let me know what you find out. I also have the latest version of Carbide Motion on my PC.

I had this once also it’s typically due to tolerances and settings related to tolerances for arcs

Here is the GRBL documentation for 33:

The motion command has an invalid target. G2, G3, and G38.2 generates this error. For both probing and arcs traced with the radius definition, the current position cannot be the same as the target. This also errors when the arc is mathematically impossible to trace, where the current position, the target position, and the radius of the arc doesn’t define a valid arc.


you may be able to get around it by changing these:

$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)

Or if you figure out the line of gcode maybe update it. But that might be a challenge if you don’t know the correct numbers to update.

I managed to run it for close to an hour without any problems. I didn’t realize how long it would take. The CM meter only showed 7% complete and I had to leave. My spindle motor got pretty warm!

Jerry, thanks for trying. I appreciate you taking the time to help. I probably should have warned that it was a very long set of g-codes and that it would take several hours to run. Hope I didn’t waste to much of your time.


No problem. You actually helped me. I don’t normally run long jobs so I didn’t notice. I discovered that I might have a bad motor driver board. Gonna email support and see if they can help me out.

Thanks for taking the time to help Roger. This makes a lot more sense after reading the GRBL definition for error 33. Since the error was raised during a cut, I can eliminate a G38.2 related error. That means that it is either a G2 or G3 error. While I’m not sure what line of code the error is in, I can help but think that it may be the result of my settings in Fusion 360 CAM when I generated the cut. I may have the settings too tight, or it could be an inches to mm rounding error. I may try and regenerate the .nc G-code file with different cam settings. I’m not sure if anyone has posted any guidelines for CAM settings related to the Nomad, but that would be helpful. @robgrz It would also be helpful if Carbide Motion would display the last G-code line number executed when an error is raised. This would certainly help in the trouble shooting process when an error is raised.

Here are my Fusion 360 CAM settings for the Pocket Passes:

As for your suggested work around, I’m not sure where I would go to find these setting you referenced:

Is that something that is in Carbide Motion? or the GBRL code on the Nomad 883 controller? or the carbide3d.cps Post Configuration file in Fusion 360? Sorry for such a Noob question.

I really appreciate all you help on this Roger.

Ouch. Sorry to hear that Jerry. I hope that is not the case, but I’m sure they will help you get it resolved if it is.

The Nightmare Is Over!!! :relaxed:

I have solved the problem and wanted to share the information with the forum. Hopefully this information helps others. The issue seems to be with the number of decimal places used for accuracy and the handling of mm to inches conversion. My fusion 360 drawing was done using mm as the units of scale. When I ran the CAM, I selected inches as my units since all of the end mills sold by C3D are in inches and since most of the specs on the machine are listed in inches. ( work area listed as 8" x 8" x 3" and speeds are listed in inches per minute.) Even though my CAM file units were in inches, and my end mils were in inches, I kept wondering why Carbide Motion kept displaying the X, Y, and Z in mm while homing and marking the work zero location. @rogwabbit Roger’s response about GRBL documentation got me read the GRBL standards to see if I could come up with anything. Ultimately, I decided it must be a rounding error on the conversion from mm to inches. I went back to Fusion 360 CAM and made the units conversion to mm and then edited all of the fields to display only 3 decimal places (rounding up or down as necessary) since GBRL is only accurate down to 0.001mm. I did the post process and ran the updated file and Bingo, it worked. I could have saved myself some time and real headaches if this was better documented. I have since found that this issue has been around more than a year as evidence in the below thread. Wish I had read the whole thing earlier, but I’m glad I figured it out.

Here is what my project looks like after milling. I have come clean up work to do on it, but I’m very impressed with the level of detail.

This took job took 12 hours to complete and was done with a 1/16" Flat end mill and a 1/32" flat end mill. I plan on cutting this in brass plate next and will share more details when I do.



Here’s another trick with F360 - you can use meshcam with STL’s exported from fusion as well, but there are some weird things that happen if the units are not consistent. You can do all you want with your design in mm, but before you export an STL, set the units in the design to inches (in the tree on the left) Meshcam won’t necessarily ask you what your units are when you import and will default to inches, so everything will be all out of whack for scale and getting it fixed on the meshcam side is…ugly.

awesome news, glad you got it working without having to modify the grbl settings.
the arc tolerance could be increased to “Tolerate” bad arc calculations in theory to answer your previous question. I was able to up mine one time to get over the error, but ultimately it’s the g-code generating software’s fault to begin with and having the correct precision definitely is the best route to take to resolve the issue.