CNCjs and bit setter

I’ve found the bit setter macros for cncjs but am confused as to the operation of the second one. It just throws a soft limits alarm on my machine. The first one I set my location and all works as expected. Hoping someone could shine some light on this for me.

Turn off soft limits.


Hi @Siggies ,
The new tool macro will not work correctly unless you’ve run the initial tool macro.
Can you give more details on how you came to the soft limit issue?

1 Like

I encountered the soft limits issue by just running the macro. tried it a few times, no dice. The first macro I ran I put in my machine cords for bit setter, ran the macro from homing position. Went to my bitsetter did what it was supposed to do no issues.

I had my soft limits turned off, didn’t take me long to smash into something. I’ve been looking at adding proximity sensors all the way around but have yet to pull the trigger on anything.

On a side note I ran a stream deck with UGS is there a hotkey section in cncjs? Or do all my hotkeys need to be written in a gcode format?

You’ll find all CNCjs hotkeys in this source code file:

The user guide has them too, but as far as I can tell they are not all mentioned, so the source code file is best.

Did you run the New Tool macro AFTER running the Initial Tool macro?

I figured it out, user error. Thanks for all the help!

1 Like

Glad you figured it out.
Can you share where you went wrong? Others can learn from it.


Not 100% sure. I think it was my order of operations.

Turn machine on
Run homing
Set zeros on work piece
Run initial tool macro
Run job
Change tools
Run new tool macro
Run next file

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.