CNCJS Bitsetter sending Alarm 4

I have been playing with CNCJS now for a few days. Everything was working fine with the help of Neil Ferreri Ω macros. Set in my location of bitsetter and had it all working well until this morning when it started burying into the bitsetter and sending me a Alarm 4 Probe Fail. Sent out “?” And got this


Checked the bitzero, lead was not in contact with it… opened CM and it is still functioning as it should
Not sure why this started out of nowhere. Any help would be appreciated. Thanks!

Do you have a BitZero also?

1 Like

I do… sorry, when I said I checked the bitsetter and lead, I meant I ensured the bitzero was not contacting the magnetic lead

1 Like

And you have checked the function of the BitSetter with your finger, making sure that the light works? Does the console show the triggering of the BitSetter and the BitZero?

There was something similar on the forums earlier about the CNCJS alarm 4

1 Like

Red led light is present and working properly and the 3 axis bitzero macro is working properly except for a discrepancy in the height when complete which seems to be about 3 mm high off the expected z 0

Does the probing op stop before reaching the BitSetter ? If so you may just be running out of Z travel. Try increasing the PROBE_DISTANCE in the macros, see if you still get the error.

2 Likes

Unfortunately it is. It is burying into the bitsetter… so every time I try and make a change and check it is hiting the bitsetter. I try and kill the power to mitigate the amount of force being put on the bitsetter.

Sorry I missed the “burrying” part in your original post. And yet when you open the Settings page in CM, the BitSetter shows “PROBE” when pushed and nothing when released ?

1 Like

@griff37m
What’s your $13 value. I’m guessing it’s set to inches (1)… Can you change it to mm ($13=0) and test again?
That setting won’t impact your design or gcode.

2 Likes

My $13 value is 0. Just really frustrating how it happened out of no where. I have tried reinstalling CNCJS and redoing the macros.

And correct, in CM… it indicates probe in the settings screen. Thanks for showing me that, did not know it was there

In the pic in your initial post, should’ve looked earlier, looks like you have your Z probe location set to -79.8mm.
That location should be where you want it to start probing, distance below the limit switch and ABOVE the actual bitsetter. You can start probing anywhere ABOVE the bitsetter, and that setting is just to speed things up on the initial probe. I’d set that much higher (less negative), like -15 and go from there.
What I think might be happening is you’re activating the probe on your approach, so when you start the G38.2 you’re already in an active probe state and the probe will fail.

2 Likes

Neil beat me to it, which is only fair considering those are his (wonderful) macros :slight_smile:

2 Likes

Awesome! thanks Neil, that was the fix. Also Thanks to all who responded for the help. Now my new problem is with the “new tool” macro. All operates as it should, it’s just when I go to continue the job with the new tool, the cutter is about 50mm from where the original material z is.

can you detail the steps you took?

it should be

image

Is your g-code file generated from CC or Vcarve (which requires a specific post-processor)?

3 Likes

Thanks Julien, I was missing the “initial bitsetter” macro step. I was just running the 3axis probe macro and then starting the job. Thanks again and now that I have a handle on CNCJ, I think I’d going to be a huge asset to work flow. Thanks again to everyone for the help!

1 Like