CNCjs, feedrate converted to mm even though G20 (245.4 KB)

I’m new to CNCjs - this is my first time using it. I have a file created in Carbide Create (build 474) attached.

In CC, I set my feedrate to 90 IPM. I see this in the gcode (G20 on line 6, and F90.0 on line 18).

However, during my air run, I noticed the feedrate is 2286 when I expected 90, because my units is set to Inches (G20).

Why did CNCjs convert the feedrate from inches to millimeters when my units is set to inches?

1 Like

Hi @ericlin,

CNCjs just displays whatever value was reported by GRBL live feedback, and GRBL happens to default to mm units for that status report, regardess (I think) of the G20/G21 codes being executed.

You can change this behavior by setting $13 GRBL parameter (“Report Inches”) to 1, and then the feedrate in inches per min will show up in that field.


Where do I set the “Report Inches” parameter?

Grbl parameters are stored in the EEPROM — you interact with them by sending commands to change them, so for instance in Carbide Motion you would go to the MDI tab and send

$13 = 1

to the machine.

Reporting in inches has been known to cause some rare issues with BitSetting in CNCjs.


Interesting, I did not know that. Better be cautious and stick with reporting in mm then (which is easy for me to say, being metrically-inclined :slight_smile: )


They’re stored on the Arduino, not the computer running the Gcode sender? Why is that?

Grbl has an option for reporting in either measurement system — where else would that preference be?

The question rather would be why CNCjs doesn’t accept the reports in whatever units they might be in, and then convert the measurements as appropriate.

I think you want them to stay with the machine. You’re trying different senders, someday you may switch computers. It’s a good thing the parameters are stored on the controller.


This topic was automatically closed after 30 days. New replies are no longer allowed.