CNCjs Interface Stops Responding

I’ve been using CNCjs with my Shapeoko for a few months now and I really like the flexibility. Being able to write my own macros for it is a real time saver if I need to indicate a part a specific way that wasn’t set up in Carbide Motion.

That being said, I have had a lot of reliability issues with the interface. So far the actual g-code sender has been pretty stable, but the interface has tons of issues. It will stop updating and become unusable for minutes at a time unless I reload the browser, sometimes when I click buttons nothing happens and I’m not sure if it’s delayed or didn’t get the signal (very dangerous for jogging), and just general weird behavior.

I’m running both the server and browser on an rPi 3B+ since I wanted to have a fanless setup to keep chips/dust out of the “computer”. I can’t seem to find a lot of useful information about this issue online, but it seems like some people have it, others do not. I’ve made sure to provide my pi with a high output power supply to make sure it doesn’t have low power warnings (these made it wrose), but I’m not sure if there’s anything else I can do, or if the pi just isn’t powerful enough for this task (or there’s something else wrong).

Does anyone else have this issue? Is it stupid to assume an rPi can run both the server and browser?

I run the CNCjs server on a rPi and use it via a browser on my Chromebook. It works well and I am pleased with it.

However like you, after running a few jobs after each other the web interface becomes unresponsive for no apparent reason. I usually reset the browser and all is well. I cannot tell why this happens but it really is just an annoyance rather than a critical problem for me. I believe my rPi 3b is way more powerful enough for this simple task.

BTW - my rPi is on 24/7 and works flawlessly - I probably have not needed to reboot for 3 or more months.

1 Like

Yep, I have that issue. The browser refresh button is about worn out … :rofl:

It could be the network connection between the client machine and the Pi, how stable is the wireless?

If you were really bothered it would be worth inspecting the logs on the rPi and the webserver log in CNCjs to see if the client connection is getting timed out.

Could you please post the locations of those log files?

From a quick look (I only have CNCjs working on OSX at the moment) the main app log appears to be;
$HOME/cncjs.log

Raspbian (again, not got a running one to log into right now) seems to be the standard /var/log/messages for the main system logging, not sure if CNCjs sends anything to here but the system certainly does.

Network errors it seems are both messages and syslog, see here for an example.

Beware, you will likely need to be a bit of a software nerd or Linux nerd to understand much of what’s going on in those logs. Developers tend to write log messages for themselves, not other people, no matter how much you apply positive or negative reinforcement this is a hard behaviour to change.

@LiamN, my rPi is running both the browser client and the server. Clearly this shouldn’t be a networking issue since it’s connecting to itself via 0.0.0.0 (I think).

I’ll take a look at the logs and see if there’s anything to be learned. If the error is only client side though, I don’t anticipate the server would know anything about what’s going on. I doubt there’s any kind of heartbeat being transferred back and forth between them.

Yep, on the one machine it’s not going to be a loss of packets, it could still be a server session timeout issue though if the interface is just left running.

There may be something informative in the logs about a new session being setup or the existing session being timed out by the server though.

This is probably something to go ask about in the CNCjs support group, I don’t imagine that Shapeoko users are the only ones to have seen this, if we are then there’s something quite specific going on.

Yeah, I realize this isn’t the perfect place to ask for help on this specific issue, but I’ve found that this forum is more active and generally helpful than many others I’ve found. I was really hoping I was just doing something stupid that everyone else had figured out and they’d tell me how to fix it :smiley:

1 Like

Well on the upside, at least if you have to go to the CNCjs forums you’ll have met the first “did you check the logfiles?” hurdle :wink:

This has been a thing for a while. It happens on the desktop app as well. I’ve only noticed when I think a job is almost done and I get ready to do something else.
Although I’ve seen it more than once, it’s not repeatable. I know the issue had been reported, but I’m not sure anything was solved. I’ll see if I can track down that issue.
Edit: here it is. Add any info you can.