Computer crashes

Why is it that when I turn of the Shapeoko controller my pc crashes?

Please let us know step-by-step what you do, and what sort of computer you are using. Have you patched/updated your OS? Do you have problems with other USB devices?

Usually I shut down my machine, Carbide Motion notes the disconnect and then I quit out of the program.

Will, computer is Win 10 Pro, fairly new with all win updates current.

During a oops sessions, shapeoko at its mechanical limits but stepper motors are heading full steam a head into the rails. I reach for the kill switch and turn off the power immediately. Then I get the blue screen of death on the computer.

I have used Windows since there was a Windows. I used to get the blue screen of death on previous versions of Windows. When I was on Windows 8.1 with a Toshiba Laptop I occasionally got the blue screen of death because of some defective memory DIMMS. Since I have been on Windows 10 I have not gotten any blue screens of death on my HP Laptop. You will have to research your USB settings because it sounds like it is related to the USB when you shut down the Shapeoko. There are a lot of settings for USB buried in Windows. The interrupts are likely the cause and tuning USB settings may help.

If I kill power to my machine, even if CM doesn’t crash, I restart the computer since I want things to be in a known state.

What happens if you:

  • power up and connect everything from a cold start
  • with CM connected and controlling the machine (say sending an air cut file)

and then cut power to the machine? Do you reliably get a crash on the computer?

Its hit and miss on the crash. Newbie here making mistakes, hit hit the power button to stop the Shapeoko sometimes win 10 crashes more times sometimes not.

I’ve cut power numerous times and pressed on with CM with no crashes. Good thought process to restart from a known state. Thanks for that thought, going to implement as part of my process

Next crash I will take a look at the System Event Log on next boot up.

Haven’t had a crash after I changed:

  1. Hard Drive NEVER power off.
  2. USB NEVER power off.
  3. Display power off after 10 minutes.
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.