Connects but won't move

I installed the HDZ last week, everything went fine. Flashed, updated etc… Played with the manual movement some. Turned it off. Got everything in for the suckit dust boot for it. installed everything, it went good, played with it some all good. I was reading on the forum here about the rapid movement issue. So I tried it. yep it has the issue. rehomed it and when it got all the way in the back corner it gave me an error about disconnection. I power cycled the machine and turned it on, tried to initialize it, CM says busy and then these two errors come up. None of the accesses are moving. Tired to resetup the machine like in the HDZ direction. It reads the controller, sends the data, all the limit sensors show up.

whats more puzzling is if i push the X & Y gantries back to the limit switches (resting on them), connect and initialize, the X and Y move off the limits switches about 1/2" and it sits there and I get the error again.

in the settings screen, it will show in the status hwich limit switches are pressed
easy thing to do is check each of then X Y Z one at a time to see if you get the expected view…

(also I am suspicious about your z limit… that one goes first, and it seems your x and y might work)


Maybe something came loose when CC slammed the HDZ to the left rail upon using rapid position?. You should check switches individually:
as @fenrus said you can go in the settings page, trigger each switch manually, and CM should display something if it detected the switch activation, and you should see one of the LEDs light up on the controller.
If they all do work when triggered manually, pull your X and Y far away from the back corner, launch homing, and watch the Z axis movement : does it go all the way up and make contact normally (or dies it grind for a few moments) ?
Maybe capture a video of that for additional clues.

1 Like

In my first post, towards the bottom I said all the limit switches show up. I mean, when I press them it shows up on the screen. I know they are working and not showing pressed when not.

So today, I tried to initialize it and manually pressed and released the Z limit switch and it homed. The Z didn’t move at all. So I opened the drag chain to see if the Z motor came unplugged…it was not. I reseated the connector. Did not fix it

Now there is a new problem. I noticed the motors stopped humming for a second, came back on and then went silent again. I unplugged the main power and plugged it back in and after 20 seconds it did it again.
Here is a video of what happens. You can faintly hear the motors but you can see the power light dims over time.

Took the controller cover off. you can see the main power light, turn on and then slowly go dim to off completely.

I checked the voltage on the power supply and two pins are at 24 volts.

So I unplugged everything from the controller and power cycled the unit again. It does the same thing.

So I unmounted the controller from the machine plugged in the power and check the pins on the back side of the board, both had 24 volts.

Here is a picture of it with power connected and nothing is plugged into the board

Nothing on the front or back side has any signs of “foul play” it doesn’t stink like it burnt up.

Is my board bad? Power Supply?

Update for anyone wondering. Sent an email to tech support and all of the troubleshooting I have done thus far, points to a bad board. Just purchased a new one, hopefully be up and running in a few days

Thanks @Willadams for your help!!!

1 Like

Installed the new board yesterday and everything is back up and running!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.