Controller error, now won’t home

I was using my Shapeoko XL last night to finish up some last minute Christmas gifts. The job was three different set ups. The first two went fine. After flipping the part and re-zeroing carbide motion had a couple of errors. I think they said “cycle aborted” in a red box at the top. Then the program lost connection with the controller and I had to power cycle everything and re launch carbide motion.

Ever since then my CNC will not complete a homing sequence. When I try to initialize it, instead of the z moving up, it moves down and then carbide motion flashes something about “door open” before saying that homeing has failed. I even tried UGS and the same thing happens when I try to Home it there.

This is what I have tried so far to fix it: first I changed the “home direction mask” $23. No luck, it still went down. Next I tried a complete reboot of everything again, powering down the controller and restarting the laptop. No luck there either. So I went for drastic measures reloaded GRBL using the GRBL updater, then resent the machine parameters. Still no luck, did exactly the same thing. The last thing that I did was launch UGS and override the intialaztion sequence and verify the z still moves up when it is supposed to. Everything worked perfectly (except for homing). I could even use it to run the g-code and finish the job.

Does anybody have experience with this that can point me in the right direction for something to try next? I am planning on sending this in to the support email as well, but wanted to know if I was overlooking something.

Make sure none of the limits is already hit(pressed) when starting to home. Sounds silly, but I’ve had this happen on my xxl multiple times. I just power down and pull everything out a bit and then it starts fine.

1 Like

Hi, I can confirm that there seems to be a problem with homing. Motion kept telling me it’s already homed, but only x and z was. Manually moving the axis away from the switches “fixed” the issues.


1 Like

Fixed! @Jorge and @WillAdams from Carbide Support were awesome and help me diagnose the problem. My Z Limit switch was failed. I soldered in a a replacement one tonight and I am back up fully functional again.


I had an interesting version of this on my new XL-upgrade unit. I expected I had broken another limit switch (I have a bag of them from Digi-key) but the limit was fine. Turns out the Z track wheels had loosened up enough that the Z plate was actually missing the limit switch at the top. I am constantly tightening the Z wheels (and the X) but never had it actually slide past the limit switch.

1 Like

Just a shot, but you might try loosening the screws that hold the eccentric nuts. Tighten both with an allen wrench and wrench on nut with the eccentrics leaving the v wheels loose, then adjust v wheels again only turning the eccentric nuts clockwise. Adjust the first “almost” tight, then tighten the other “almost” tight, go back and forth till both are tight enough to prevent the wheel from turning by hand easily and the axis moves smooth. Mine haven’t loosened up again since doing this. On the z axis this “back and forth” is really important as uneven v wheels can actually put your spindle off axis. If you can’t get the Z axis to tighten evenly and through full travel, check to see if the rails for the Z axis wheels are perfectly parallel and vertically square to your base.


1 Like

Did they send you a replacement? I’m having this issue with a completely new machine…


Please contact us at and we’ll do our best to help you.

@Msonst They offered to send a replacement, but I had one on hand so I told them it was OK and just used the one I had.