Converting .c2d Files for Carbide Create?

I am not having very good luck converting downloaded .c2d files (ones that currently do not open up in Carbide Create) so they can be opened by my Carbide Create program like the directions say in the following link.

I am totally new to this and obviously do not understand the process. Is there a good video on this somewhere, the ones I have found do not go step by step and program versions seem to be different? I keep getting errors, maybe my path is not correct or something. I am using a Mac and using IDLE.


I have not tried converting older files via the link you posted.

My files have been easy enough to recreate in the current version of Carbide Create.

Did you try InkScape?

Maybe I am just doing something wrong then, why are some .c2d files grayed out? I am trying to open your sunglass file in Carbide Create.

I just downloaded the file to test the link.
What I do is I open the Carbide Create software, then I open the “Hardcase Sunglasses.cd2” file, it is working for me.
Want to check and make sure you have the most recent version, 286?

This is what I get when I try to open it, grayed out. I tried dropping the .txt from the file and that did not work.


Here is a screen showing that I can open a .c2d file.

That Hardcase Sunglass file should be 11,546KB it was too large to post here- is your file the same size?
I wonder if its not completely downloaded?

Try opening this file:
clamps and blocks for Nomad.c2d (845.8 KB)

I figured it out, with your help, and wouldn’t have if you hadn’t have sent that file size for me to check. I went to file properties to make sure the file was at least that big and saw another way, on the Mac, to change file extensions and when I did it showed up in Carbide Create ready to use. I don’t have near the experience on the Mac as I do on the PC and sometimes it takes me longer to figure the Mac side out.

Thanks for the help.

1 Like

I don’t understand why CC can’t open .c2d files when it saves this type of file? I have saved a project from CC, but it can’t open it.

Create a simple test project, save and reload… does that fail?

1 Like

I can’t even load the saved projects.

In that case, it’s likely a permissions problem.

Ensure that the account which you’re using to load Carbide Create has read/write for the folder and the files in question.

1 Like

I’ll check on that then

Right click and run CC as Admin, as well.

1 Like