Crashing Z after "insert tool" w/ carbide create

I don’t have this problem when I use Fusion 360, but with carbide create the following steps cause a crash:

  • Initialize
  • Manually Zero machine (bitsetter disabled since I’m using a surfacing bit)
  • Load file
  • It raises the Z to near the top, then asks to insert the tool.
  • I click resume and it goes to the proper X-Y starting point for the job, but continues traveling upwards and crashes Z

I had this same problem with the Hello World test on day 1 with this machine. Any tips? I’m ready to just throw Carbide Create out.

Can you try homing the machine and then sending “G28.1” (without the quotes) using the MDI tab, see if that fixes the problem ?

What do you have the saftey/retract height set for?

It was set to the default: 0.4724in

Does this mean it will always retract that far regardless of current Z position upon startup? And if so, this seems like a bug in the software. When it raises the Z axis for the tool insert, that’s not a command I added.

And, also if so, why would anyone ever want this setting to anything other than zero? It sounds like a problem waiting to happen on every… single… job (as I’ve experienced every time I use carbide create).

If there wasn’t 0.472" above where zero was set, this could cause the problem.

It’s useful for clearing clamps and the surface of the stock.

But the problem is that it’s retracting again after already raising to the top on its own for the tool insert.

What am I missing because this sounds like a bug

Provide a .c2d file, generated G-Code, step-by-step notes on how you are securing your stock and setting zero and managing any tool changes and a photo showing an attempt at cutting still in place on the machine.

I don’t have the .c2d file but here’s the gcode: · GitHub

I sent your support a note the day I got this setup, but FYI you can reproduce this problem on a stocke XL Pro, with a clean install of carbide motion, and your own Hello World file. Follow the directions precisely and it will crash upward.

What type of Z do you have. Have you resent the config with your machine type, Z type and any accessories like BitSetter (or unchecked for what you are doing) and BitRunner (automatic router control).

Sounds like maybe you have the wrong config for your Z. The latest CM 536 has changed the default machine travel (softlimits). Are you running the latest CM and sent the config?

The default soft limits keep you from crashing during jogging but if you send commands to exceed the travel of a machine nothing prevents it from hitting the limit and trying to keep going and grind away.

1 Like

I simply set the machine config as XL Pro, but otherwise followed the directions from the assembly doc precisely.

Version is 517, OS X, and says “No new versions available.”

I haven’t made other changes.

Please try manually updating to 536:

Whoops, actually 517 was my carbide create version. Carbide motion is up to date.

Apparently at least some copies are missing that 536 is available. Please try it.

Yeah, I double checked that it’s 536, thanks


Hi, as @gdon_2003 asked above, what z-axis do you have? Belt loop z, z-plus, or hdz?

It’s a stock XL Pro, so whichever that comes with.

The Pro XL comes with a Z-Plus but I think you can upgrade to the HDZ but not sure about the HDZ.

We will be offering an adapter plate which will allow upgrading to an HDZ on the Pro models.

The SO4 should work as is (but would require that you revert to the smaller V wheels) — it may be that we’ll offer a new version w/ relocated holes which match the new wheels, or maybe the HDZ will become a Pro only upgrade — check in w/ @Luke and co.

Right now we’re exploring how best to adapt a HDZ for the 4 and pro. I think we’re close but we still have work to do.