Cutter did not respond message when connecting to SO3

I am having problems connecting to my SO3. I have downloaded the latest Carbide Motion for windows. When I plug in the USB cable, windows device manager properly recognizes and lists my SO3 in the “ports” section. The blue power light is lit on the carbide motion 2.2 controller board. I bought my SO 11 months ago and performed a “hello world” sharpie test successfully. I had to set the machine aside for a few months and now she won’t connect.


We have a knowledgebase article on this: — EDIT: link for that is now

Please try those things which are easy / convenient for you, and if it still doesn’t work, contact and we’ll puzzle it out with you.


I’m having the same problem with my 883. The only thing I can think of that may have affected it is moving the z axis by hand once and it stuck then moved quickly. I wonder if I may have burnt something out on the board from the current created?

-Power on the computer and 883 - tried powering them on in different order - same result
-The 883 control board light and fan come on
-Carbide Motion appears to connect to the 883
-I click on “Jog” and it just sits there with the message “homing the machine”
-The steppers are not locked so they aren’t get any power sent to them

The link didn’t help because there’s not enough information to complete all of the steps unless you have enough prior knowledge.

Any other suggestions?

Contact and someone who actually understands this stuff will get you and your machine squared away.

I suspect you’re going to need a new control board.

Turns out I accidentally plugged one of my limit switches in one pin off. The C3D support guys asked some questions that lead me to noticing the problem. They were friendly and quick to help. Looks like they are getting their operations down now.

1 Like