Cutter "loses" its way? UPDATED Meshcam waterline issue

Hey all, I need help.

Tonight for the third time (all on different cuts, two on different computers hooked up to the Nomad Pro) a cutter has walked away from its programming and ruined a work piece.

I was cutting a charm with our company logo in it, and on a waterline cut the cutter kept going in the -X direction, ruining the work piece. You can see the issue on the left side of the “E”.

Any help would be appreciated, please let me know what additional information you may need to help me figure this out.

Part was fixtured securely with step clamps, as well as two sided tape.

Waterline cutter path


Im not sure the best way to put my .nc file up so Im trying to attach it here. Any help would be great.

Thanks in advance.

charm 01 .031 waterline (6.8 KB)

Could you also share the specifics of:

  • what this material is
  • what feeds and speeds were used
  • what cutter you used, and whether it was new or no

Thank you for the reply.

Material was Aluminum, 6061

Cutter was a kodiak cutter
Size Shank Diameter Length of Cut Overall Length Flutes
0.016 0.125 0.048 1-1/2 2

Was not a new cutter, but in very good shape. Was cutting good with decent chips, no rubbing, about 10 minutes into the cut.

Feed: 4"/min
Waterline cut at 0.002’ step.

Do you have any machinable wax or similar material? I’d try a test cut in that w/ a new cutter to verify the machine, then work up some sort of test cut you could do in scrap w/ the old cutter. If both work out, try again?

One further thought — if you’re going to have a hole in the part, why not pocket that first, then put a sacrificial aluminum fastener into it?

Hopefully it was a worn bit or anomalous difficulty — if not, I’m sure someone will have some better suggestion, or you could contact

I re-ran the same program with a different bit (brand new 0.25’ BM) in an extruded piece of foam, so I could verify there was no impact of the cutter on the error.

The result was a repeat in the pathing outside of the boundary.

So I assumed I would see something strange in the G-Code (please note I am new to all of this, so I was unsure what I was looking for other than a weird X POS). I did not see anything obvious in the coding, but I probably missed something.

To verify the issue was in the coding, I ran the same program through a simulator, and the bad routing was not there. So I am assuming it has something to do with Carbide Motion. I will try to contact support if no one here has any other ideas?

Repeat failure

Simulation result (ran multiple times, cutter never went off path)

1 Like

Quick update,

        I just ran another waterline path, and it happened again. Totally different path, different boundary, different cutter settings.

So I plugged it into the simulator and noticed an error when it was trying to load the path. I went back and put in the original file I had an issue with and it had the same error. The error shows up on the bottom of the last screen dump in the sim software. Appears to be an issue with waterline paths in Meshcam, NOT Carbide Motion. Or operator error.

@Randy Have you ever seen this before?

1 Like

Good bit of troubleshooting. Thank you. Please send the source file, the CAM settings, &c. to MeshCAM support and hopefully they’ll be able to puzzle it out.

Thank you William, I hate not understanding something, so it drives me to root cause.

I have updated the title to this thread, and sent an e-mail to meshcam for support. I will post updates here and hopefully close the issues for others.

I have also sent a retraction e-mail to Carbide support (I emailed them before finding the error in the sim), hopefully they see that before spending any time on the issue.