Cutting too deep (aspire, Carbide motion, Pro XXL)

I have a brand new (actually it sat in the box for almost a year, but I just put it together last week) Shapeoko Pro xxl and am having problems with my first cut.

I am new to CNC, but have had a lot of 3d printers and am getting to know the differences.

I downloaded a simple STL file of a cross and used it to create GCODE in Vectric Aspire.

My first attempt failed because a d 5" file tried to cut a 5mm object.

But, now what should have been a shallow object carved into a block of wood resulted in my but going into the wooden slats and damaging the aluminum rails.

I have the Bitsetter and it seems to work correctly. It pushed the bit onto the button, then adjusted until it was just barely touching. I thought that would prevent the machine from ever going deeper than that point?

Any suggestions?

How do I upload a file here?

When I jog CM and tell it to go to 1 inch above the zero it sits perfectly 1 inch above the surface of my router bed. The Gcode file viewed in CM says the thickness of the part is 18mm and the depth below zero is -0.03mm; I think that should be 0, but its going almost an inch past that.

I am using vetric aspire and when i set my wood size and cutting depths I am setting the zero at the top of the piece. I tried as a test to change it to the bottom to see if that changes anything, and it does not. The bit still tries to start below the wood, in the bed.

Hi @turk187,

Welcome to the community.
Did you have a chance to check out the tutorials at
It’s important that you have a good grab of the zeroing and tool change process (I’m not saying you don’t, this is just generic advice for folks who are just starting with CNC)

See this for a generic list of possible root causes for cutting too deep:

Not, the BitSetter does not do that, it will just adjust Z zero between tool changes. The lowest the endmill will go depends on how/where you set your Z zero, and how deep the gcode then moves it down.

if you upload your gcode file and share details about how you setup your stock on the machine and how your set your zeroes, we may be able to figure out what happened.

1 Like

What Julien said…I know when I downloaded the new versions of Carbide Create and Motion recently, I also forgot to check where I was setting my zero on my file. Normally it was defaulting and I wanted the Z to start on top of the material. With the new versions, it was defaulting to the bottom of the stock and I didn’t catch it in time before it plunged into my waste board. Good lesson to learn to check all your settings in both the tool path program and then on the processor side as well! I am new to CNC and am not always as detail oriented as I need to be. Guess I will be moving forward. :stuck_out_tongue_winking_eye:

1 Like

On the recommendation of a friend I have switched from Carbide Motion to Universal G-Code Sender. I already like that better and have not had the same problems.

This topic was automatically closed after 30 days. New replies are no longer allowed.