Don't Machine Top of Stock

When using MeshCam, in the Toolpath Parameters there is an option within the “Finish” section “Don’t Machine Top of Stock”. I checked this option but it didn’t produce the results I expected. The finishing path still includes moving the bit back and forth over my entire work area. Why is the bit moving over areas that are not needing to be machined?

I have almost no idea what I am doing, but it appears to me that a minimum this wastes time, but it is also not performing smooth movements and even adjusting the Z height in these areas. Seems like it is not only wasting time it is also putting unneeded wear on the Nomad 883.

I can (and have) defined additional “Machining Regions” for this next attempt, but as I am completely new to CNC and MeshCAM I’m curious, are there are better ways to accomplish this?

I left a project running overnight and during the night the tape under the left side of the stock material started to let go. The tape held but the left side raised up (maybe a mm). Since the bit was dancing around in this area it left a pattern showing how much the bit moves on the Z axis and how it is not moving smoothly across the X and Y.

I tried using the “Machine geometry only” setting, but when I did that other areas no longer got rough cut.

After spending more time defining machine regions here is what the finish toolpath looks like…

In this project things are being cut into the wood, the bit is still spending time moving back and forth over areas that are “top of stock”. It appears the more time I spend defining machining areas the less time the project is estimated to take. But I have no idea if this is the best solution, suggestions?

If you are working from a bitmap input, MeshCAM will trace the whole bitmap even if “Don’t machine top of stock” is chosen. I have not found a way to get around this yet.

Your solution of machine regions is currently the only reasonable workaround.


Thank you Randy, yes I am working from an image. At least now I know what I need to avoid.

The project that the Nomad is currently working on is not going well, the top of the stock is getting machined. Looks like I need to find a way to “trick” MeshCAM…

Maybe if when I start the project I set the Z point a mm above the stock, then alter the design so the cutout area is 1 mm deeper I may be able to avoid repeating the above problem.

Before applying tape, sand the bottom of the workpiece to ensure it is flat then wipe with a clean cloth. In my case, very little sanding was necessary but it has made a significant positive difference. When dealing with several workpieces, I use a sheet of sandpaper clamped to a reasonably flat table.