Driver fails to install


I just got my Shapeoko 3 set up and I can’t get the drivers to install.

My machines (tried on two so far)

Zotec box with windows 8.1

Custom box with i5, 16 Gigs RAM, Windows 8.1

I have tried Carbide Motion 3 and 4. Run as administrator, and not. Restarted after each uninstall. I attempted to have the Device Manager look in the folder holding the installer for drivers.

Nothing. Each time the wizard pops up and ends with a “driver failed to install” error.


Any advice would be appreciated.

I figured it out.

The carbide drivers are strong text signed unsigned. It would be helpful if the error message , or some point in the installation mentioned that. I figured it out because there is a will entry detailing which 64 bit operating systems have issues. They all have one thing I common: none will install unsigned drivers by default.

1 Like

I believe that you mean “unsigned” in your second sentence — that would explain a lot.

1 Like

Still leaves a good point…why aren’t they signed?

I did mean unsigned. I made the appropriate edit.

I think the unsigned drivers account for a few of the issues people are having, and the systems on the wiki that are listed as not working.

Just checked with one of the devs — the drivers are signed — if they show up as unsigned on your system, please forward the specifics of your system and a screengrab of the window indicating that they’re not signed to and we’ll hopefully manage to track this down.

Turns out the driver signing wasn’t timestamped or some such thing, and when the certificate expired, the signing ceased to be valid.

Hopefully a new version will be released presently.

Got it. Glad you were able to track it down!

Not me, @robgrz — I just hack in (La)TeX, HyperCard/Runtime Revolution, Powershell, and am learning Python.

I too had the USB Driver fail to install and found this thread while looking for the fix. I can say that this has not been addressed yet in the latest version of CM.

Anyway, while this thread explains why it fails to install it does not explain how to fix it. I Googled “how to install unsigned windows 10 drivers” and found this article: How To Geek - Install Unsigned Drivers I followed the directions and attempted the install again. When it got to the driver install portion of the process this time instead of just failing with no explanation, it gave me the option of installing the driver even though it was unsigned.

Maybe this has been addressed in a later thread but I couldn’t find it.

FYI: My setup is a Dell laptop running 64 bit Windows 10.

Grab the latest from and it’ll be signed correctly.