Error 9 Homing Cycle Failed

Hi gang…connected my lap top for the first time… tried to home and the cycle failed. Error(9) Homing Cycle Failed… Error(10) GRBL Error: Homing Failed, couldn’t find limit switch.

Please help

Look limit switches .

We have a basic page on troubleshooting the homing switches at:

Please make sure that each switch lights up the matching light on the controller when closed and that the machine can mechanically close each switch along that axis before reaching the limit of travel along said axis.

If you continue to have trouble let us know at and we’ll do our best to help you work through this.

I went through this problem for almost a week Brandon called me last night went out and connected to the machine and limits and homing worked fine. Didn’t adjust or move anything, and still don’t know why but believe he’s a miracle worker or something. good luck cause I sure don’t know.

1 Like

Perfect… Thanks, my wiring harness was binding and the limit switch was not making proper contact.

1 Like

I bought a used XXL and it consistently fails to go home. I usually just restart the homing and it passes. I feel that it may be the drag chain on top of the gantry but I can push the Z axis easily with the power off. Since it does not seem to stop me I have ignored the issue since I can get past the problem by simply re-homing. My issue is always that the Y axis gets about 2-3 inches from home and just stops, fails homing and simply re-homing the thing works. The cut quality is perfect and not causing any other issues except during homing.

If you’re on Grbl 0.9 you may have the original homing defaults which were intended for the SO3.


$25=1000.000 (homing seek, mm/min --- on larger machines, consider increasing to 1500)

Go to the MDI and send


and you should be good to go.

Thanks for your reply. I am running Carbide Motion 4.x so I am above 0.9 grbl. I am at 1.x something (not in front of the machine). This system is from about 2017 so do you think that the MDI command would still help since this machine was surely upgraded. Or does this parameter you suggested get updated during the firmware upgrade?

It should have been updated when you sent your machine configuration:

You can check what this is set to by going to the MDI, opening a log and sending $$

Usually homing problems are caused by things getting hung up somehow, or the machine not being perfectly square so that the wrong corner touches first. See: and

Super frustrated. I’ve check everything listed in the troubleshooting faq and still nothing. I’ve checked all switches and all light up as mentioned in a separate thread. I get no movement at all when trying to home.
I tried to run a simple job I did in create and the z axis drops down and chatters. Only movement I’ve gotten. Please help

Please check in at if you haven’t already.

Have you seen:

If it moves down when you begin homing you probably have the Z-axis spindle carriage plate installed upside down (the static pulley should be on the left), or the machine is miswired.

Thank you. Sending to support now. Pulley is indeed on the left.

The drag chain may have been the problem. I moved the anchor to 3 inches from the frame and took one of the two screws out on the Z carriage end and moved it away from the Z axis and secured with one bolt. That seemed to help get the kink out of the drag chain. I did make sure that the router cord was not binding along the side of the drag chain. Time will tell.

1 Like

Removed all zip ties, loosened drag chain to rest freely on rails, all switches light up in controlled box when engaged with finger. The only movement I get is z axis going down and chattering. I sometimes get a z axis limit stitch error but not always. Did anyone else that had similar issues not get any movement from x or y axis? Anyone experience similar issues with z axis ?

When the machine homes it does the Z-axis first.

The Z-axis is supposed to go up to the homing switch then as noted previously:

If it moves down when you begin homing you probably have the Z-axis spindle carriage plate installed upside down (the static pulley should be on the left), or the machine is miswired.

I guess the machine is miswired as you can see the pulley on the left in the picture I posted.

All harnesses appear to be wired in the same color coded order. Could miswiring be internal in the motor?

Start by sending the correct machine configuration:

If something is miswired — all wiring extensions should be straight through, and all wiring connectors should be consistent, stepper motors may be reversed in several ways:

  • swap the left and right pair of wires
  • reverse the ordering of the wires in the left or the right pair
    reverse all four wires

Do whichever is appropriate to match the other wiring connectors — use a small tool to pop out the wiring lead pins and when reinserting them, make certain that they click into place. See: Reuse and-or extend the Molex connectors

If that’s not it, let us know at and we’ll get this sorted out.

William is the man!

White and green wires were reversed on the connection for the control box. Got it homing

I has posted on this thread about my intermittent homing error and Will suggested the drag chain. I re positioned the drag chain and my homing errors went away. The drag chain was hitting the bolt that holds the Y axis switch and was stopping it from going all the way home.

1 Like