Error after homing-GRBL error: G-code words consists of a letter and a value. Letter was not found

Hello, I am using a Shapeoko 3 XXL and have been getting the message “GRBL error: G-code words consists of a letter and a value. Letter was not found.” every time I try to home the machine. I have fully updated my carbide motion to the latest version, but it still, will not work. I have also tried it with different computers but still, get the same error. I think that the problem might be in the control board, but I have no idea how to fix it. In earlier versions of carbide motion, I was able to get around it. I would run the tool path then stop it and jog it to the origin, then hit resume on the control panel. With the new update I have to hit initialize machine and that is when the error pops up.

I saw that there was a post about this in October of 2019 but there was no solution stated, and I was not able to reply. GRBL error: G-code words consists of a letter and a value. Letter was not found

Hope that someone can help. Thank you.

This shouldn’t happen when homing — most likely you are getting dropped connections for some reason.

What USB cable are you using? How long is it?

What computer are you running Carbide Motion on?

What version of Carbide Motion are you using?

Do you know what version of Grbl is installed on your machine?

The cable is a 3 foot USB PRNT cable.

I am running carbide motion on a Windows 10 x64.

I am using the most recent update of carbide motion. Build: 542 Released: 10-15-2021

I am not sure what version what version of Grbl is on the machine.

Thank you for the reply.

The control board was updated in 2018, because the last one broke.

It is Grbl 1.1, since CM builds 4 and 5 will only connect to Grbl 1.1

Does your USB cable have ferrite beads?

Please let us know about this difficulty at and we will do our best to assist.

The cable does have ferrite beads.

I think that the problem might be in the Grbl in the machine. Is there any way to reflash the software?

I will also email as well.

Sounds like EMI to me
I suffered the same this month but mine was happening during a carve
I rerouted my cable but did not help
It happened every time on the same carve at the same place so I turned my router speed down and it stopped
This however will not help if it’s happening during homing
One way to stop EMI is to wrap your cable around something round at least eight times ( if you ha e enough cable, this will make a choke that should stop it, better still wind it it around a ferrite ring

1 Like

Yes, one can reflash, but usually the software is a binary thing, either it works, or it makes exactly the same error in exactly the same way, at exactly the same point each and every time.

Cue Edsger Dijkstra intoning,

Anyone who believe computers are capable of generating random numbers is in a state of sin.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.