Error code 25 - Gcode word was repeated

I’ve had my machine now for a year or so and have never had any issues with the coding part. This morning I was working on a new project and when I try to run the file in Motion I keep getting a Grbl error that says “a Gcode word was repeated in the block”.

Having never received this message before, and not being a programmer, I’m not sure what’s going on. I use Carbide Create to make my files and have had no issues to date.

Any ideas about what is going on or how I can get the file to run properly?


Hi @mrflach,
Can you post the G-code file here for a look ?
Does the problem still happen if you re-generate the G-code from the design file ?

1 Like

Here is the file. I tried to redo the file and run it again and got the same outcome.

Hey @mrflach, the file upload didn’t work.

Let’s see if this works. Too big for direct upload.

Where do you get the error?
I’m most of the way through, and I don’t see an error.

It gives me an error within the first minute of starting to run the program. First time I ran it the error message came up in 10 seconds. I shuffled the order of the pathways and tried again, which is when the error message came up at about the one minute mark.

Sounds like a Serial Communication issue.
I ran a check on the whole file…no errors.

Can you do an aircut? (Router and Vac off, no stock or zero above stock, just make sure you leave enough for about 3/4" retracts)


Just ran an aircut and same result. Tried another file and it worked just fine.

First, reboot. Then, please try testing the file in check mode.

Go to the MDI and send


then send the file — Grbl will process the file without moving the machine — if you still get the error and your computer OS is fully up-to-date and you are using current versions of Carbide Create/Motion please send the file and the file which made it in to and we’ll do our best to look into this.

1 Like

That’s what I did, but in CNCjs. I doubt Motion would have a different result.

1 Like

Yes, but Carbide Motion rewrites the G-Code on the fly — it can be fussy sometimes, and it’s possible this is some sort of edge-case.

1 Like

Thank you all for your help. I was able to get it running again.

A little embarrassing but I think it was the updated Motion program that I downloaded and forgot to install. After doing so it worked perfectly.



This topic was automatically closed after 30 days. New replies are no longer allowed.