Error: Cutter not found - Pi Build 578 / Pro 5

I also a getting the “no cutter found” error from my Raspberry Pi 4 8gb driven Nomad 3. It worked fine Two days ago before I updated the system software.

1 Like

Not to be a pest… But any projected date for this?

Thx Rob!

We think CM6 is almost ready to move to “released”, and then we’ll do a Pi build.

Looking at some of the back and forth, it sounds like the “Not Found” is a permission problem triggered by an update to the Pi platform. I don’t think it’s anything we can change, that’s something that needs to be changed in the OS or by the user of the OS. If that’s correct, someone with better Linux-fu than me should be able to post a command to drop in a terminal window to fix it.


The notes I have on this sort of thing are:

Note that Linux users may need to add their account to the “dialout” group to access the serial port.

If running UGS says “no serial port found” you need to do this. You can test by running UGS with ‘sudo’. If that works, add yourself to the ‘dialout’ group.

To find out if you, the current user, is in the group dialout, use the command:


If you do not see dialout listed, add yourself with the command

sudo usermod -a -G dialout *username*

If that doesn’t work, let us know and we will dig deeper.

1 Like

Just confirmed my user is part of the dailout group.

Looked at /usr/local/bin and noticed that bCNC is root while carbidemotion is my local user. So I played with permissions and no luck. I inspected the process and I am seeing that the dev/ttys0 is busy and so is ttyamco. When I listen to the ports via screen no traffic occurs. When I follow the same process on a usb printer I get traffic.

Fresh image, new user, same results.

1 Like

Check the permissions on the serial port?

Root: dailout 660

User(s) added, removed, re-added to group

I think the clue is that bCNC works over the port with the same user to the machine. I think the library in motion for opening the port is deprecated.

1 Like

Hopefully that will help Rob when he does the next version.

If it is a permissions issue you should be able to work around it by launching CM with sudo - has anyone tried that yet?

1 Like

That’s a bit sticky, but…

root@raspberrypi:/home/car# /usr/local/bin/carbidemotion
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
[13:51:37] [ I ] [thread 6982] Carbide Motion Start
("/usr/share/icons", ":/icons")
[13:51:37] [ I ] [thread 6982] Font Loaded: Roboto
[13:51:37] [ I ] [thread 6982] Font Loaded: Roboto
[13:51:37] [ I ] [thread 6982] Font Loaded: Roboto
[13:51:37] [ I ] [thread 6982] Font Loaded: Roboto
[doctest] doctest version is "2.4.9"
[doctest] run with "--help" for options
[doctest] test cases:  11 |  11 passed | 0 failed | 0 skipped
[doctest] assertions: 359 | 359 passed | 0 failed |
[doctest] Status: SUCCESS!
[13:51:37] [ T ] [thread 6982] SetMachineState() INIT 
Main Thread ID:  QThread(0x1749490, name = "Main Thread")
Lambda Thread:  QThread(0x178fa68, name = "Machine Thread")
Machine Thread:  QThread(0x178fa68, name = "Machine Thread")
error: XDG_RUNTIME_DIR not set in the environment.
Enumerating ports 
Port #0,ttyACM0, ->,  4358:13443 , isBusy=0
Port #1,ttyAMA0, ->,  0:0 , isBusy=0
[13:51:40] [ T ] [thread 6985] ERROR: Cutter not found

No change in behavior

Good News…

I doubled down on updates and bumped to 12 (bookworm). CM works as expected.


Can you post a link to the build/release of the OS you used?

Distributor ID: Raspbian
Description: Raspbian GNU/Linux 12 (bookworm)
Release: 12
Codename: bookworm


@tbeeler did you do a fresh install of bookworm or did you upgrade from bullseye?

Upgrade from Bullseye, pretty straightforward

I’ve tried launching Carbide Motion with sudo with same results.

I even rebuilt Raspbian using username pi with password raspberry (which Raspbian was VERY unhappy about :laughing:)

Sorry sudo didn’t work. I’ve decided to move on from a Pi to a Windows machine I got for very little - nice little Celeron box - hopefully it will do the trick :slight_smile:

Thanks Tim this worked great!

For those that do not know how to upgrade from bullseye to bookworm…

use nano to edit the files /etc/apt/sources.list and /etc/apt/sources.list.d/raspi.list

nano /etc/apt/sources.list

and …

nano /etc/apt/sources.list.d/raspi.list

change the word “bullseye” to “bookworm” in both files

use ctrl+x to save

after the changes are saved run the following command…

apt update

then run…

apt full-upgrade

follow the prompts for any decisions that are asked during the upgrade.


Yup, that’s what I did. It seems snappier too, but your mileage may vary.

@brandon Glad that you found this helpful, thanks for posting the upgrade. I guess it’s not as obvious to some?