Error: Cutter not found - Pi Build 578 / Pro 5

I am scratching my head here, looking for ideas on further isolation of the issue.

Been successfully using a Pi 4b+ with Motion 578 since day 1. Today went to start a job and could not connect to the cutter.

I can connect and initialize if I connect the same USB to my MacBook. Reboots, updates, and trying different ports yield the same error.

$ lsusb displays: MCS Shapeoko 5. But short of that, I can’t figure out why motion won’t open the connection. There are no other obvious options for me to triage this further.

Willing to try any suggestions to get this job running

1 Like

Does the USB port work for other devices?

yes, other devices work on USB. I pulled all USB devices and only plugged in the controller… no change…
[ 2.532332] usb 1-1.4: new full-speed USB device number 4 using xhci_hcd
[ 2.650235] usb 1-1.4: New USB device found, idVendor=16d0, idProduct=0fa7, bcdDevice= 0.64
[ 2.650269] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.650287] usb 1-1.4: Product: Shapeoko 5
[ 2.650301] usb 1-1.4: Manufacturer: Carbide 3D
[ 2.650315] usb 1-1.4: SerialNumber: Shapeoko5Pro

1 Like

OK, I have isolated it to Motion, and was successful in loading bCNC and jogging the machine.

I have removed and reinstalled Motion, still unable to connect. I am assuming I patched something and I have a newer library.

1 Like

It could be a permissions thing. I forget, but I think the installer has to give the user rights to connect to the port. If you’ve done anything wonky to the Pi or the user, the permissions might be off.

1 Like

I’m having the exact same issue. I reflashed 32-bit Bullseye onto a brand new SD card and redownloaded the newest CM build, and am still getting the “cutter not found” error.

When I SSH in lsusb results in:

Bus 001 Device 007: ID 16d0:0fa7 MCS Shapeoko 5

and usb-devices gives me:

T:  Bus=01 Lev=02 Prnt=02 Port=03 Cnt=02 Dev#=  7 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=16d0 ProdID=0fa7 Rev=00.64
S:  Manufacturer=Carbide 3D
S:  Product=Shapeoko 5
S:  SerialNumber=Shapeoko5Pro
C:  #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=500mA
I:  If#=0x0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=00 Driver=cdc_acm
I:  If#=0x1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm

Works fine on my Silicon MBP.

Did either of you do a apt-get update or upgrade recently?

Yup about a week ago, after completing a job. Then I double downed on updates after installing bCNC. Haven’t had a minute to play with permissions.

Have you rebooted the pi since running the updates?

I did an update about 2 weeks ago and have not had any issues.

1 Like

Yep, the night before it stopped working and then did a reboot.

We’re in the middle of a big CM update that should be ready before too long. We’ll have to see about updating our PIs to the latest OS when we do the PI builds to see if anything broke over time.


Food for thought - Your millage may vary

I did all updates and upgrades to an existing install and it still works.

I downloaded the Pi OS image with suggested apps from 5-3-2023. I did an install using user pi and password raspberry. I then downloaded the Carbide Motion image and installed it. I then performed all updates and upgrades. It still works. I strongly suggest changing the password from raspberry for security.

Why this works, is purely a guess on my part. I suspect the “pi” user is still granted permissions from the old days.


That’s interesting, like we talked about yesterday I changed the username off of the default pi.

I’m not at home currently, but later this afternoon I’ll re-image a card with the default username and see what happens.

Thanks, Brandon!

Not sure if I am following.

I am running a pi with a different admin account. I disable “pi” account post-install for security.

I haven’t had a chance to inspect the permissions and although it’s possible it’s the culprit, I am skeptical because the same user account is able to communicate over the same port using the same qt5 library with a different application (bCNC).

To be honest I am considering reflashing the os and starting fresh. The only reason I haven’t is that getting at the SD card is a pain due to the screen enclosure

Half an update.

Reflashing my card with the 32-bit OS from 5/3 and the user pi (with a non-default password) got it working.

I’ve got to get a few backlogged projects cut so I’m not going to run a sudo apt-get upgrade on this image because I’m a coward.

When I get rid of my backlog I’ll make another card and give it a shot again with updates and see how that works, which will be tomorrow evening or Tuesday morning realistically.

Interestingly OctoPi also requires pi as the username during setup.

Appreciate you working on this, Brandon.

@Bee got an update for you.

Wrote a new card today with the 32-bit OS from 5/3, username pi, password raspberry, and the hostname the default raspberrypi. That worked fine.

Updated, rebooted, Carbide Motion broke again.

Updated Package Version
base files 11.1+rpil+deb11u7
chromium-browser 113.0.5672.95-rpt1
chromium-browser-10n 113.0.5672.95-rpt1
chromium-codecs-ffmpeg-extra 113.0.5672.95-rpt1
cups-browsed 1.28.7-1+deb11u2
cups-filters 1.28.7-1+deb11u2
cups-filters-core-drivers 1.28.7-1+deb11u2
liboupsfilters1 1.28.7-1+deb11u2
libfontembed1 1.28.7-1+deb11u2
libpam-systemd 247.3-7+rpi1+deb11u2
libssh-gcrypt-4 0.9.7-0+deb11ul
libsynctex2 2020.20200327.54578-7+deb11u1
libsystemdo 247.3-7+rpi1+deb11u2
libudev1 247.3-7+rpil+deb11u2
libwebp6 0.6.1-2.1+deb11u1
libwebpdemux2 0.6.1-2.1+deb11ul
libwebpmux3 0.6.1-2.1+deb11ul
xplug-bluetooth 0.33
Ixplug-cutemp 0.11
Ixplug-menu 0.4
Ixplug-network 0.33
Ixplug-ptbatt 0.21
Ixplug-updater 0.14
raspberrypi-sys-mods 20230510~bullseye
rp-prefapps 0.47
rpi-eeprom 16.1-1
rpi-imager 1.7.5+rpt1
systems 247.3-7+rpil+deb11u2
systemd-sysv 247.3-7+rpil+deb11u2
systemd-timesyned 247.3-7+rpil+deb11u2
udev 247.3-7+rpi1+deb11u2

For now, I’ll go back to an un-updated image, take the Pi offline, and return to Sneakernet for file transfers.

1 Like

I suspect it might depend on the type of Pi, this is on a Zero W2 for me.

Thank you

1 Like

Pi 4 B 8 gb here.

I’ll have to see if I have an extra Zero 2 W floating around to try, I think I actually might.

1 Like

Yeah, I’ve got a pi400 (rbp4 8gb) and this is not working with the current Raspbian build. lsusb shows the hardware recognized, but no joy connecting to the cutter.

Would love to see Carbide do a new Motion build for the pi.

1 Like