Error using GSender and Shapeoko 5

Machine starts the job fine then will do a random move and stop. It gives out a GCode error. Usualy error:33 (Invalid g-code ID:33) but sometimes error24 as well.

I have tried changing up the post processor in F360 from the Carbid 3D to the generic GRBL. I have ensured the Unit is in MM as well. I understand the issue is likely related to error while computing an arc but I am out of ideas on how to fix it.


Can you post your Gcode file? (7.3 KB)

I ran it in CM and it worked perfectly fine, so I am confused…

What version of gSender are you running?

1 Like

I was on 1.21. I just upgrade to 1.4.3 and Il report back if that fixes it.

1 Like

“Strip comments sent to controller to prevent buffer overflow and better support Shapeoko”

The S5 has an issue with certain gcode comments. Not an issue when using CM because it strips them all before forwarding gcode to the machine. Anything after 1.4.1 should fix it, though I have not tried it yet.

1 Like

@Ganfan If the errors are inconsistent, it sounds more like an issue with the serial communication. If you run in check mode ($C) do you get any errors?

1 Like

Were you using feed rate override when the errors occurred? Version 1.2.0 and 1.2.1 had issues when using feed rate override. This was fixed in v1.2.2

This topic was automatically closed after 30 days. New replies are no longer allowed.