Error while starting filestream: null

I have a new machine that I’ve set up with an HDZ and the sensor package that Mr. Beaver has put together. Creating gcode in Fusion 360 and using the nightly build of UGS platform.

I can send my touchplate gcode without issue. However, when I send other gcode that I’ve created in Fusion I get " Error while starting filestream: null" and it won’t go beyond that.

I am sending my gcode as grbl - but have also tried the carbide preset in fusion. I think it’s a setting in fusion but haven’t tracked it down yet.

Thoughts anyone? Thanks!

We have instructions on this at:

You’ll also want to use CM 414, the new post-processor, and set min. arc size to 4mm as noted at: Fixing GRBL's G2/G3 Arc Errors in Fusion360

Sounds like maybe an issue with your version of UGS? I’d start there.

Your problem is with UGS. I have seen EXACTLY this problem. It can take a few seconds for UGS to load a file - if it has problems loading it, there isn’t much error reporting. If you press start before it’s loaded, you get exactly this problem. If you haven’t seen the file name and lines appear in the lower right part of the window (on the bottom status line) wait a bit more for the file to load.


Thanks everyone.

Ok, so I’m letting it load - that solves the first (null) problem. Now, starting from my zero point the z is going to the top and setting an alarm and stops the gcode. I should mention that before that, there is an error which pauses the gcode. In the past (on my other machine) I’ve just continued through the bad code until it starts correctly. I don’t know if it’s the parameters of the HDZ - or if the limit z might be having an issue.

Anyone have a clue?

What’s the error that pauses the gcode?
Can you share your gcode?

I had a very similar issue when first trying the HDZ with UGS and code from Fusion360.
Turned out, my $28 setting was not correct anymore after the HDZ upgrade, and by default the Fusion360 post inserts code that tell the Z to go “home” (G28 G91 Z0), i.e. the top of the Z rail

I solved it by homing, then typing:


which (re)sets the $28 home position.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.