First Cut - Weird Issue

So I got my machine built and did the paper hello world test with success.

I set up a simple file with 6 parts designed in illustrator and CAMed in Carbide Create. Basic 1/4in endmill doing an outside cut through material with tabs. When it executed, it did one pass around the first part, and then somehow the entire file/drawing shifted down about an inch. the second pass proceeded to overlap the first, and 2 of the parts were hanging off the bottom of my stock as a result of the shift.

I tried re-cutting the 3 bad parts and the same thing happened. Any help would be much appreciated!!

Please post the file, both .c2d source and generated .nc and a description of how you’re setting the origin and we’ll try to help you puzzle this out.

You should also check your pulleys, i had my set screw back out on the X axis and it would move and act crazy during cuts. I also experienced this when i was having disconnection issues.

1 Like

I appreciate the input - I will take a close look at them, but I am skeptical because this happened twice on two different runs both at the same time and jogged the same distance down and then the rest of the file completed correctly.

The render in Carbide Create was correct.

Attached are the files. I set the origin as described in the hello world tutorial - jogging to the bottom left corner and zero-ing all axis’. The first pass around the first part was clearly in the right place, but after the shift down everything finished down about an inch

BedTray.c2d (70.3 KB)

nc File Attached (85.7 KB)

Had a simular incident when test cutting my dust shoe. I was using Fusion 360 and another CNC user’s file that also included the assembled model positioned above the disassembled parts. I changed the the bit to the one I wanted and then recreated the paths. I then moved the parts out from under the model so I could see the model and parts easier. I then saved the cut file and then tried my test cuts. The first peice came out perfect. And then the machine went crazy and started offset cutting over the first piece. When I lokked at the file again in Fusion 360 again I noticed the cut layout was showing the cut paths were under the model (where the parts were before me moving them) and not with the part. I had to then reopen each part and rebuild the paths. The next test cut worked great. I learn something new daily with Fusion 360. It makes sense now that when I moved the files after the intial changes that I also left the cuts in the original space therefore trying to go left of Y.


So I’ve been pulling my hair out today over this issue. I’m more convinced it’s G-Code related and not the machine. I ran it a second time on a piece that was previously cut so that the machine was not under any chip load and it did the same thing. It was at the top right corner of the top right piece where I hear a grinding noise and I checked the Y axis and there is no slipping of the belt. I tried drawing a square in Carbide Create and it ran fine - I tried running another file that was made on the computer and it seemed to run fine.

Any idea are much appreciated!

Usually the motor skipping steps. Are you reaching the machine’s limits? Basically, is the gantry crashing at the top of your design? Was the first pass dimensionally accurate?
Another possibility could be a loose / broken connection on a Y stepper

Gcode is fine…no reason to cause what you’re describing.

1 Like

That file has a slotting toolpath which is difficult.

Please try adding geometry and cutting as a pocket insofar as is possible. Adding geometry to cut as a pocket with a finishing pass

For feeds and speeds please test

Bingo this was it - being the total newbie that I am I didn’t realize there was so much un-usable space towards the back. Thanks for all the help!!

While this wasn’t the source of my problem I used this technique for my re-do and while it took way longer it resulted in a very smooth final cut.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.