First Setup - using Carbide Motion on Debian

I have a Shapeoko 3 Pro that I bought over a year and a half ago. My main workstation is an iMac in my study in my house and the Shapeoko is in my workshop in the barn. I’m hoping, by the end of the year, to add an iMac in my workshop, but for now I have a Linux workstation there (on Debian) and I have a Raspberry Pi connected directly to my Shapeoko via USB. It has a touch screen interface and I’ve installed Carbide Motion on it, too.

I hooked it up one day and didn’t get to finish working with it. When I came back the next day, I ran CM and couldn’t connect to the printer. I power cycled the CNC and it could connect. So I tried “Initialize Machine.” Every time I do that, I get 3 errors:

“Machine controller restarted unexpectedly and may be in an undefined state.”
“GRBL Error: Homing Failed, couldn’t find limit switch.”
“Homing Cycle Failed”

I don’t know what order these happen in, but the foremost error dialog is the first one and the last one is behind the others. This happens after the router carriage has only moved a little bit. It has not moved to a side or all the way up or down so it would trigger any limit switch. I’m not sure which direction to go to troubleshoot this. Obviously there’s a communication error, but I’m not clear if it’s trying to read from a switch and not getting data or if the communication is breaking up.

What should I try or work on next to get this working?


A couple notes, since this came up previously. Although I’ve changed my setup by adding the Pi, which is on the table beside the Shapeoko, at this point, I’m stuck with Linux down in the shop. Trying to get a USB cable from the main workstation to the Shapeoko is far enough it’s going to lead to tripping and I have other tools around, so I do not want that hazard - it’s dangerous. (Especially for me!) I have explored other ways to connect, but since I saw people had good things to say about the CM .deb file, I went with that. One alternative might be UGS or something like that - a program that has been on Linux much longer and has time to have any bugs related to the OS worked out.

Hi @Tango,

The short answer is : contact support@carbide3d.com and they’ll look into that with you.

But since you are here:

  • for now I would ignore the “Machine controller restarted” error message, it may just be leftover from when you power cycled the machine
  • to troubleshoot homing, the first step is to check whether all three limit switches operate correctly. I’ll assume you have the inductive limit switches:
    • go to CM’s Settings menu, Machine tab. You have a “GRBL Active input pins” section there
    • check that section before initializing the machine: it should say “no active pins”.
    • bring a metal object near the face of the limit switch: “X” or “Y” or “Z” should show up as an active pin, when you trigger the corresponding switch
1 Like

Sounds good - I’m so used to every company saying they have support and being tough to reach that it’s become a habit to just deal with a forum or go on Stack Exchange or Reddit for help. Good to know I can count on Carbide3D!

I have the default setup. I can check on them tomorrow.

That much I can check on now, with VNC. Yes, it does say “No active pins.”

Okay - I can check on that tomorrow. Thank you!

1 Like

Called Carbide and talked to Josh and got it fixed. I had not updated settings so it was working with the older system where it thought it was moving the carriage up and not down.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.