Flashing green and red light on board

So my machine was running great and for some reason I updated something on universal Gcode sender and suddenly my machine doesn’t home in the X direction any more. It homes the z first and then it used to move x and y at the same time, but now it only moves the Y direction and I can’t for the life of me figure it out. I now have red and green flashing lights on the board. All connections are fine, nothing happened besides updating UGS. Could that have altered the GRBL settings? I tried to look up how to re-flash grbl 1.1 but couldn’t find the instructions/hex file. My $$ settings are:


not sure if something should be different. I think when I installed the j-tech laser I had to change something here… Thanks for any help

If I hit $X it will work, but I’ve never had problems homing before. Oh, and I hit the reset button on the board multiple times. No dice

What happens when the Y completes it’s homing cycle? Without that info, it sounds like your X switch is already pressed (or damaged).

1 Like

So what happens when it homes in the past is it does Z first and then moves x and y diagonally inwards until they touch. Currently it only moves y back though–doesn’t even make x move at all. Very bizarre. And x is not pressed or stuck. Machine is locked until I enter $X to unlock it. Know how to reflash grbl 1.1? I can’t find instructions. I remember using carbide motion previously but I can’t run it because a .dll or something is missing. I uninstalled and reinstalled carbide motion 3 and 4 several times with no luck–same error each time

What happens when it completes the cycle? When it tries to home an fails.

It homes z, then y, then it stops. It stays locked because of an alarm. ‘alarm 8’ It says that the controller attempted to do something unexpected or something though… I’ll be back in the shop Monday and can copy/paste the exact message, but it’s along those lines

Sounds like a false trigger in your switch. Can you send a ? through the MDI and report what the response is? I’d bet you’ll see a Pn:X in the report, indicating a pressed X limit switch.
Check the wiring on your switch, manually push it a few times, and check that ? again.

How do I do that in universal gcode sender? Do I type something into the command line?

Yes sir, just a single ?

Going to work in the shop tomorrow, I’ll check it out. So, hit “?” and if I don’t see “Pn:X” it’s something else, but if I see that and after pressing the switch a couple times and it still happens i probably need to replace the limit switch then, right?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.