Freezing and loss of Z position

I need some help with diagnosing a problem.

Though I’m traveling, the team that’s teaching CNC using the Shapeoko XXL are having problems. “We were getting several red warning messages, occasionally it would freeze, and the “Z” axis would frequently loose its zero reference.” I’ve asked for the error codes but wanted to start off with this description.

Do these symptoms ring any bells?
Can we get some help figuring this out?
Hopefully it’s a familiar and easily fixed problem. :crossed_fingers:

1 Like

Sounds like EMI, and a lack of familiarity with re-homing the Z.

Any sort of troubleshooting like this goes more easily if the folks with the problem describe it step-by-step:

  • what you were doing / what you did before the problem arose
  • what you expected to happen / continue to happen
  • what went wrong / what actually happened that you weren’t expecting to happen

Could be EMI but we’ve put clip-on ferrite rings on all cables since we too thought it might be that. As for zeroing, the instructors know very well how to do that and drill the procedure into students.

A repeatable scenario to cause the problem has evaded us. In the past we’ve looked for one because we realize it’s key to problem identification and resolution. Perhaps in this most recent round they’ve seen one. I’ll ask.

Thanks for the quick reply.

1 Like

Loose Z axis belt, maybe skipping teeth? Does it fail when running the same chunk of G Code? Have other known working G Code files been tried? I’ve also lost Z steps when my spindle retracted too high prior to running code, hit the limit switch, kept going and skipping belt teeth, then lowered way too far and killed my material.


1 Like

If you could post a video, we’d be glad to look at it — alternately, if the location has Skype or FaceTime, have them contact and we’ll someone who’s really a wizard w/ that fancy video stuff help them directly.

1 Like

I am one of the instructors who was teaching last night. We did have cases where the Z axis was driven too high, and where the bit was driven into the work piece, however we zeroed Z after both of these occurrences.

Did you re-run the same GCode after rezeroing? It will do the same thing over and over if so. What finally fixed mine was to lessen the retract height/clearance height.


1 Like

Both the Over and Under Extension were at the start of the zeroing process to there was no GCode involved.

Maybe post a video as @WillAdams mentioned?


Folks, Pat on our team has conducting a bunch of tests to ferret out a repeatable fail case. He has had some consistent results in triggering X/Y/Z to failure which he’ll share after he confirms his findings on Monday.

Just wanted to thank you for the input so far and to let you know what we’re doing, to explain the quiet. No, the problem didn’t go away and that’s not why it’s been quiet. :innocent:

More news in the next couple of days.


We have been able to consistently and predictably cause our Shapeoko 3 XXL to freeze.

The conditions were: The router was turned off and no other machines were running in the shop. All jobs were air cuts. Z zeroing was either via MDI or directly on the surface of the material. X, Y, anz Z limit switches are OFF. HOMING is ON. X maximum is 830, Y maximum is 850.

If no GCode was loaded (immediately after starting Carbide Motion and after homing and zeroing X, Y and Z), then we could not elicit a freeze failure. Control of the router position via the X, Y, and Z buttons in the Carbide Motion Jog screen performed without failure. All rapid positioning functions worked without failure, And repeatedly moving the router to is maximum positions was accomplished without failure. Ran repositioning via Carbide Motion Jog controls for approximately 10 minutes.

If GCode was loaded, then moving the router to its maximum Y- position (furthest Y position from HOME) would cause the machine to freeze. (Again, router is OFF, no other local machines running in the shop.) This failure was consistent and repeatable. Occasionally a failure would also occur when the router was moved to it maximum X- position. Twice a freeze condition occurred when the router was moved to its maximum Z+ position.

To restore control of the router, either of two methods were successful. 1) reload the either the existing GCode file or a new GCode file; 2) recycle the power to the CNC machine (controller and gantry assembly). Both these actions resulted in unfreezing the machine. The preferred method of restoral is #1.

We will be setting the limit switch options to ON and reducing the X and Y maximums to 825. We realize that the extreme real estate will unreachable, but this is only a test.

With this in mind… any ideas? Thank you, in advance for your help.


Thanks for the step by step! I’m going to walk through this now and see if I can repeat on my end.

A couple questions first:

  • What version of Carbide Motion
  • Windows or Mac? (Which version of either)

Thanks again,


I am not in the shop, today, so I cannot verify the version of Carbide Motion. However, I believe that it was updated, along with the controller firmware, within the last two months. I will be able to get those versions back to you, tomorrow.

We are running Window 10, 64 bit.

Thanks for helping with this.


Edward, what ever the current version of Carbide Motion was two weeks ago is what’s on that machine as that’s when I installed the update.

First - Hi Travis!

Second - thanks for the info. I’ll try this now.


OK - I ran through this on my XXL machine. I couldn’t reproduce the issue. That’s good news and bad news depending on what version of CM you are running.

Here’s what I’m running:

  • Windows 10 x64
  • Carbide Motion v4.410

If you’re running v3, the easiest thing to try is to just upgrade to v4. Here are the instructions if you’re not there already.

If you are there, let me know which build you are running and I can start troubleshooting from there!


I’ve been able to do this with Win 10, CM 4.11 >and< Mac 10.13.2 w/ CM 4.11 - jogging to any of the axis (Z is easy) switches, or too far down on z (I assume, past the soft limit) causes things to freeze. Quite CM, restart CM, and it heals up.

would you mind sending your GRBL settings to me?

Open Log, goto MDI, do $$, press send.

Settings should be in the log, just copy and past into an email please.

Thanks Mike!

Sent. Hope it helps. If you want logs with it “stuck” I can get that as well.

Edward, any insights from your look-see of the code etc?