Fried Controller?


I am attempting to power up my controller. When I turn the switch to the on position on the power supply I see the blue LEDs flicker on for about 1/2 second and then go dark. The motors “move” for a split second but after that I cannot get Carbon Motion to recognize the Shapeoko.

Any troubleshooting ideas?

I have verified the green light is lit on the power supply, rebooted my machine, tried a different USB cable, and tried the reset button on the controller. What else could I try to see if I can get it working?


I’d give Carbide a call, they can usually help out with figuring out what’s going on.


Try connecting with another sender or Arduino serial monitor. Make sure, after you restart the computer, that you don’t open anything other than the program you’re trying to connect with. Another program may be trying to connect, using the serial port.


Thanks. Unfortunately don’t have those easily accessible.

Here’s a video of what I’m seeing - (sorry for the sound).

I’ll call them tomorrow to see if I can find a fix.

Do you see the machine over USB?

If so, it’s possible that Grbl is corrupt and reflashing will fix it?

If you continue to have difficulty let us know at if you haven’t already and we’ll do our best to help.

1 Like

I just watched the video. That looks like either a power supply issue or a short.
What happens if you remove all connections, including USB, and switch it on?


Without the USB it does the same thing. I’ve also plugged it directly into the wall to rule out the surge protector.

Unplug everything from the board. You might even want to remove the board from the mount and blast it with air. That will rule out an external short.
Do you have a meter you can use to check the PSU, independent of the board?


Ah, I’m pretty novice at this and don’t have a meter. What do you think the odds purchasing a new PSU would fix this? Or can you think of anything else?

Also @WillAdams - Are there other ways to troubleshoot the short?


As I noted from

Usually the power supplies are binary — either they work or they don’t — if the green light lights up promptly and stays lit then the power supply is most likely good. The only easy way to test it is using a multimeter to verify that the switch is closing / opening correctly and that when switched on it’s providing the correct current.

Most likely your board has a problem — if it’s not something which can obviously / easily be addressed (say a chip causing a short) then the board would need to be replaced.

Wish I had better news — if anyone has any further ideas I’d be glad of them, but I’m 99% sure that a new board will fix this.

1 Like

Thanks for the very speedy response. I have no problems ordering a new board. This Shapeoko is amazing.

Thanks to everyone for the troubleshooting help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.