Fusion 360/bCNC Issue

Any Fusion 360/bCNC users out there? I just tried running it and lets just say I might have to check my tram again and am out a bit now. I started in the home position and when I hit start it basically ran all the way down to the wasteboard and just stared rapidly moving in Y.

Programmed in Fusion 360
Post processor is generic grbl with G28 suppressed

I ran the same program but with carbide 3D’s post processor and in Carbide Motion and it worked great.

I tried it with the generic and it just started racing to the lower left corner. . I killed power and decided BCNC would be for another day

Suggest using a different post-processor. List here: Shapeoko CNC Router, Rigid, Accurate, Reliable, and Affordable

Recent discussion here:

I cfan’t find any info there about bCNC and post processing. :slight_smile:

You’re using Fusion360 according to your first message… As my message there says, a bunch of the grbl posts are broken. I updated one (in the message there) that is working for me with fusion360 and a different sender - it might work for you.

1 Like

Do you think that the Shapeoko 3 Fusion 360 post processor you have there will work with bCNC as well as CM4?

I dont see why not. Fusion made a change in the post scripting defaults such that I,J,K must be “forced” - which apparently is making grbl cranky. Whether it is -your- problem or not, I don’t know, but it’s an easy thing to try.


For what it is worth, I use the provided Carbide3D post processor that comes with Fusion, and I use GrblPanel to send the code to the machine.

Thus far, besides the dreaded disconnect, I haven’t have to complain about a thing.

I got home switches, and the machine homes to the far left before starting a job.

It is working so well, I am not looking to upgrade a thing.



I just looked at GrblPanel, and it looks to be a step up from CM. The one thing it is missing compared to bCNC, is the tool change and tool length setting capability. :slight_smile: If I can’t figure out bCNC, I may go that route. Thanks.

Send the problem file in to the developer?

I’ve been looking around and I’m going to recheck the post with some new information. I may have formatted the tool change procedure imporoperly, or not saved it when I did. That may have resulted in the odd behavior. I have a commission to do this weekend, and I will be making a touch plate, so I can test a few things. :slight_smile:

I think I figured out my issue in bCNC. I had it set to do manual tool changes without a probe. It doesn’t seem to like that option. Making it ignore the M6 command had the machine working properly. This inspired me to make my own spring loaded touch plate to properly automate the ability for me to set my origins and change tools easier. It will be spring loaded (4 springs that sit in the recesses in the base). There is the base, a frame for the touch plate, and the touch plate itself. The springs will push the touch plate up to a recess in the frame. The spring loaded touch plate will assure that I do not micro-chip bits. The wire will bolt to the bottom of the touch plate, the other will clip to the tool, and both will run to the proper pins on the motherboard. I will likely have a disconnect as well.
Hopefully I get the aluminum for this tomorrow and start cutting. I know I’m over-engineering this thing, but it is also more exercise in Fusion 360, both CAD and CAM, as well as to help me gain more practical knowledge.

1 Like