Fusion 360 cam misshap with rapid first move

Hi guys.
My fusion 360 standard GRBL post processor and also the easel post processor does a weird thing (seeing as i dont have limit switches on my cnc).

When exporting Gcode from carbide create the first rapid move looks something like this:

But my fusion gcode looks like this

This makes the machine rapid without lifting the Z (and as my Z0 are also stock0 this presents a problem)… After that it lifts the Z to late obviously.

Easel behaves as expected also

G1 Z3.00 F228.6
G0 X100.00 Y100.00

Is there a workaround for this in fusion? Is it possible to add something in the post processor maybe? sadly both easel and carbide create arent suitable for the kind of advanced cam i need to be able to make.

I’d strongly suggest you put the homing switches on the machine - it’s required for the newer versions of cc, cm, etc, and pretty inexpensive. This makes it pretty trivial to have machine zero != stock zero. Which GRBL post are you using?

Botg the original GRBL post for fusion and the official easel post.

Do you turn on the router with it at Z0? Before I had homing switches, I just manually raised Z before starting a job.
You could modify the post processor, but Fusion is changing its inner workings soon. Might just wait to see how that plays out.

You might want to try one of the others, like https://github.com/Strooom/GRBL-Post-Processor

I wouldn’t do that unless you know what you’re looking for. I was going to suggest the post I use (modified from grbl), but it uses absolute machine references. Without homing switches, you’ll be asking for trouble worse than scraping the surface at Z0.

This topic was automatically closed after 30 days. New replies are no longer allowed.