Fusion 360 Rapid collision with stock in adaptive clearing

Hi all,

I am getrting started with some easy (I thought) woodwork on my shapeoko XXL using Fusion 360.
Here is the link of my file, so hopefully who’s willing and has got to help may do it more easily.


I have read forums and watched yt tutorials about the importance of avoiding slotting during the cut, especially with hard materials. Ok, first of all, is this something the community has a clear opinion on? 'cause I keep seeing many videos of cnc experts with full depth slotting toolpaths on 15 - 18 mm softwood and honestly I myself have done it many times during the first trials and at first I didn’t have the feeling that it was something to avoid. However now, after digging a bit deeper down into tool deflection, TEA, tool wear and so on, it makes absolute sense to me to try and avoid slotting always when possibile as general strategy, no matter the material but just as a way of thinking the project.

That said, I am working on 15mm to maybe 20mm deep plywood with my carbide #201 endmill. I am trying to clear some material around the contour with 2d adaptive clearing and some stock to leave, then I wanted to run a finishing pass with a contour toolpath.
On the 2d Adaptive I am getting a rapid collision with the stock error and after reading a lot of posts on the same issue I wasn’t able to debug it. I have tried to mess with heigths, slot clearing, stock to leave, lead in and out…still getting the really frustrating rapid collision with stock.
Also, a don’t understand the logic of the adaptive clearing in this case, sometimes it helixes down into the material even if the tool has already pluged down a few mm away, sometimes it just plunges down even if it is very close to the stock edge…very confusing
If you look into the f3d, the stock size is not defined yet and this is just a test for the toolpaths.

Secondly, I am tryng to work out the best strategy to get the result that I modeled. For simplicity I’ll refer to my project so may be worth taking a look before going on.
I have 3 TP, adaptive, bore and contour finish. the adaptive can’t clear the dogbone holes as the endmill is too big, which is ok, I am cutting them with the bore TP. However after clearing the contour with adaptive and boring the open holes, the finishing contour is trying to go around and finish the holes as well, which is not needed and takes ages, so I created a sketch to avoid that but it does not seem to be working as expected. So my question is now what would be the easiest strategy or TP order to get this done?

Sorry for the long post, and many thanks to you all.


Let’s just say it’s a worst case scenario, as the cutter engagement is maximal, and chip evacuation is not as optimal as when pocketing. The achievable depth per pass depends a lot machine rigidity, and sometimes you will hear a recommendation from someone who uses a big bulky industrial CNC, that is not directly applicable to a Shapeoko. The community consensus (well not really a consensus, more like a rule of thumb that comes up regularly) is that on a stock Shapeoko, 50% of the cutter diameter is a good value for depth per pass in wood, when slotting (with adaptive you can go much deeper). You can go deeper, for sure, but then it all depends on the material, how sharp your cutter is, whether you have good feeds and speeds and dust collection, etc…so 50% is the safe ballpark.

Winston published an interesting video yesterday showing that on a Shapeoko Pro, one can achieve much deeper DOC:

About your Fusion360 file, I’ll be happy to take a look later today, in the meantime I’ll share possible leads:

  • unexplained stock collision:
    • have you checked whether it’s not a problem in the definition of your tool AND tool holder in the library? For example check that the declared length of cut is not smaller than the depth you are cutting, which is not immediately obviously visually in the simulation
    • If you are confident that this is a false warning during simulation…well just ignore it. Fusion360 is not bug free.

It’s important that the stock size be defined accurately, because Fusion is (very) aware of the stock geometry and will use different strategies depending on where it needs to cut. A pocket right in the middle of the stock, and it will do the helical ramp there to carve inside out. A pocket that goes up to the stock edges, and it will choose to straight plunge outside the material, and carve material “from the outside in”.

Have you checked that you have “rest machining” enabled, with “from previous operations” as the option ?


@Julien , lots of good tips my man.

Defining your setup is the first step.

3d Adaptive is better to use even on 2d shapes because its more “model aware” and much easier to set boundary conditions. Using rest machining from setup stock is usually good for your first roughing op unless you are trying to cut the part out of a much larger piece of stock.

2d toolpaths you build up, 3d toolpaths you restrict with boundary selections. Imo this is the hardest thing to get comfortable with.

As far as slotting goes…its wood, its not THAT bad. I had some really good results with a single flute compression.

Another thing you can try is to suppress your holes in the drawing so Fusion ignores them. More of a last ditch effort though.


Fusion does this to me too. I just ignore it.

It really hates when I do drilling operations.

One suggestion.

Like you I stuck with adaptive clearings when I first started. Then I realized that 3d adaptive works much better for me even on 2d objects.

The issue with adaptive is that I will cut the majority our then spend a lot of time tuning all over the place cutting little tiny areas and shallow step downs for some reason. I have not found how to get rid of this. It also takes forever to generate tool paths. Especially when you have multiple objects in a single file.

I have recently gone to using 3d pocket, leaving radial stock to leave of around .020” then running a contour path with no stock to leave. This will generate tool paths nearly instantaneous compared to adaptive and will cut faster and leave a cleaner radial edge.

I have some files that cut out 40 of the same objects at once. It has always been a pain to select All of the profiles for these. So recently I learned you can right click an operation and add it to pattern then transfer that pattern to all the other objects automatically.

Using these two changes has cut my CAM design time down from hours to 15 minutes.

That is a very irritating behaviour watching the machine cut air, NYC CNC did a video about that



Check this out and lemme know what you think.

-Bore first, make sure to check lead to center to avoid a deflection line on the sidewall.

-3D Adaptive slotting around the part,i changed a few linking option to speed up your cut.

-Dropped in with a 2d contour, total of three passes (full depth) to get the outer walls into spec. With a superglue tape setup this is possible but you’ll want to ramp down without finishing passes if the part will be free once it cuts through.

The top is still out of spec due to no facing toolpath and thicker setup stock than the part.


@Vince.Fab many thanks for your contribute, I really appreciate it. However the link doesn’t seem to be working do you mind trying again? Thank you

No problem. I updated the link and it should work.

1 Like

Hey Vince, thank you so much this is exactly what I was after…as I see from your settings the magic happens tooling outside the boundary with a .27in offset and this does what I wanted without selecting any additional sketch as I was trying to do…now helix plunging happens just once, just as expected…

Still have to fully get my head round the passes and linking tabs but I tried to replicate from scratch your setup and now all it’s working fine!

@Julien thanks also for all your tips, now it’s all more clear about slotting and doc. However I don’t full understand the REST machining with the setup stock option. What’s the difference between this option and the REST with previous operation?


“From setup stock” will have the toolpath remove material that is outside your selection but is part of the stock you defined. It’s what you would “naturally” expect to happen by default, and as far as I can tell is the same as disabling rest machining in most cases. “From previous operation” is the most useful option to me, as it covers the case of following-up a roughing op with another op using a smaller tool on the same selection, to get inside the corners. Possibly repeating the process to chain multiple toolpaths with a smaller tool each time.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.