GBRL Error : Homing Failed couldn't find limit switch

I just got my Shapeoko 4 XL, and I have got everything all set up steps 1-9. On step 10 though, I’m having an issue pop up when I try to initialize the machine.

I have check all the limit switches through carbide motion, and they all are reading the correct axis.
So when I initialize the machine, It goes up on the Z axis. Hits the light and then backs off. Then it tries to line up the Y Axis, Moves to the back, I can see the limit switch light activate, but it isn’t registering somewhere and just continues to go on the Y axis until the above error message appears.

Please let me know how to fix this so I can get my machine up and running.

  • I have check the connections of the limit switches,
  • The blue lights on the board light up when activated manually
  • Tried adjusting the height of the Y Limit switch, It does detect the metal and light up.

Did you install the Y-axis Trigger?

See pg. 24 of:

If that’s not it, let us know at support@carbide3d.com

Is that the right link? It takes me to a sign in page. where i have registered and email through google, and now isn’t recognizing the email as a registered account…

I installed the Y axis trigger, and i can see it light up on the sensor when it comes above it. It also lights up blue on the Board when this happens as well.

No, that’s not the right link, let me fix it.

Things to check:

  • are the homing switches on the right inputs — when you test each does it register as the correct switch under Active Inputs on the Settings page?

  • can the machine mechanically move so as to activate each switch or do they need to be adjusted?

There is also a Carbide 3D Answer video:

For the new inductive homing switches:

Troubleshooting:

and Adjusting:

If that doesn’t help, let us know at support@carbide3d.com (and tell us what you’ve done thus far and let us know you’ve seen the above links so we don’t send them again).

Yes, i watched all 3 of these videos already and have checked that the lights come on the board, and in the program. they all match. and I have made sure that the height is adjusted. The machine goes all the way to the back, sets off the Y switch but for some reason is still coming up with the error message.

I have seen a lot of posts lately about new installs having trouble initalizing.

The most common problem is the sensors are not being triggered. Usually a switch adjustment fixes the issue.

Power off your machine and move gantry to homing position. Adjust sensors so they almost touch trigger points.

Some have been wiring or plugging up to wrong places. These problems are not common but happen. The adjustment is most common.

With gantry in home position and adjusted power on machine connect and do not initalize. Check lights on controller or active inputs in cm. If all lights are on try to initalize. The z proximity switch is different but you dont seem to be having z problems.

Yeah i have adjusted the height so that it is almost touching, and the Y sensor plugs directly into the board, so I can’t see the wiring being an issue. i’ve checked it a couple of times at this point. and Ive checked in CM a few times as well and it shows that the sensors are being acknowledged. Even when i reset CM after the error, it shows that Y is being sensed.