Getting Error code

So everything was going great today. Finished a project turned everything off. Come back a couple hours later and I get Homing failed could not find limit switch. Honest it was working fine before. I have checked my switches all are working and sending a blue light and all are showing up on the screen when I look at the settings page. What am I missing??? Also I have unpluged everything and rechecked to make sure all connections are working.

Debris around the switch or on the rails?

I will check. Would that make the z go down instead of up?

The Z will go down during homing.
Perhaps the homing switch isn’t really switching? What if you press on it? Do you see lights change?

yes if I close them I get a red light on the switch and a blue light on the control board. Also in Carbide motion setting it shows x,y,z when I close the connection
. I am stumped.

Is the switch ALWAYS closed?

With the power off, move your gantry away from the homing position; perhaps to the center. Move the Z travel up or down, too.

Then power up and see if it will home/initialize. You can send (not press ENTER) $h in the MDI section to see if it homes that way, also.


I tried moving it to a different position and get the same thing. Z moves down in a jerky motion and stops and then error. Tell me more about the MDI i know where it is but have never messed with it. Do I just type $h and hit send?

Ok tried $h send and got the same results.

Please see:

If that doesn’t help, let us know what you did at

That does not help I have tried and checked everything on there. I just sent a email.

If it’s moving down first there are two things I’d check first.

  1. Your Z switch is working. If it’s always closed, the Z will move down for the pull-off but never get there because it thinks it’s still on the switch
  2. Your Z axis wiring. Check that a connection is not loose. The jittering sounds like you may have an intermittent connection or broken wire.

I checked both by looking at the z switch there is no red light until I close the switch also I get a blue light on the control board when I close the switch.

So you checked the motor wiring as well?
If yes, could you have the wrong Z axis selected?

No everything was working fine earlier today.

Using the MDI, send a $X.
That will unlock the machine. The location it’s in will be machine zero. Then send a command to move the Z down a few mm.
What happens?


That fixed it. Thanks Neil

Ok, I give up. What did it fix? :smiley:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.