GRBL 1.1 and Carbide Motion 4

(Andy Clancy) #161

OK now I am losing it. when I run a test v-carve project the z-axis rams into the limit switch?
Please, someone help me get back to my old firmware.
I was so happy with my old firmware and UGS.

(William Adams) #162

Please see the second post visible in this thread:

(Andy Clancy) #163

(Uno Atmega 328 and 115200) went thru 1st time…I guess that was one I did not try :slight_smile:
Now when I try to jog in UGS I get a lock error and in carbide motion jog moves at a super slow speed at any setting?
I know I am close at least have 0.9 back on so Thank you very much.

(Andy Clancy) #164

I’m back :slight_smile:
rest to defaults
Thank you gents for your help, this forum is fantastic.
Enjoy your Easter

(Andy Clancy) #165

OK I spoke to soon, My Z axis crashes into homing switch as soon as I run a job in UGS and Carrbide???
__________$$ ___________
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=255 (status report mask:11111111)
$11=0.020 (junction deviation, mm)
$12=0.010 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=100.000 (homing feed, mm/min)
$25=1000.000 (homing seek, mm/min)
$26=25 (homing debounce, msec)
$27=5.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=40.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=5000.000 (z max rate, mm/min)
$120=400.000 (x accel, mm/sec^2)
$121=400.000 (y accel, mm/sec^2)
$122=400.000 (z accel, mm/sec^2)
$130=425.000 (x max travel, mm)
$131=465.000 (y max travel, mm)
$132=200.000 (z max travel, mm)

(Dustin S Tilton) #166

$132 - Z Max Travel should be 80mm.

(Andy Clancy) #167

I did have it set to 80 but I was going nuts and started pulling info off the web.
I will set it at 80 and try again. Thanks

(Dustin S Tilton) #168

Do you have homing switches? If so, make sure to turn on homing as well. And I’m not sure when you are crashing the Z, but if it is at the beginning of a cut, make sure you are not retracting too high in your toolpath settings.

(Andy Clancy) #169

set to 80
homing off
vbit set at correct location on work piece
reset zero for all axis
click start and z heads straight for the sky???

(Dustin S Tilton) #170

In the lower pic, change the Home / Start Position Z setting to .25". Your Z set to 3.5", which is why it is shooting up so high.

(Andy Clancy) #171

A huge Thank you I am back carving again.
very much appreciate everyone’s help.

(Brad) #172

Is this considered stable now?

(Ivan Nix) #173

I pinged Carbide3d on Twitter the other day, and they indicated that the official new release GRBL 1.1 CM 4, plus probing was going to be release in the coming week. I hope this comes true.

(Jim Amos) #174

With probing??
Oh please Carbide… re-incorporate the number pad jogging with this latest release!

(Dan Nelson) #175

I would like this post 20 times if it were possible. The hugest thing holding me back from CM4 is the 10 key jogging issues I had when I updated(only seconded by being unable to set machine boundaries and crashing my dust boot). The smoothness of CM4 as well as the ability to tweak speeds during a cut are super awesome, but it’s a huge no-go for me without 10 key jogging working unfortunately. I am really hopeful that those issues are corrected. Probing would be super cool too :sunglasses:


(George McBay) #176

I’ve got a Shapeoko 3 with the homing switch kit installed. When I attempt to update to grbl1.1 using either CarbideUpdater or XLoader (using the hex file included with the CarbideUpdate package) I cannot get the firmware to update. CarbideUpdater correctly recognizes that my Shapeoko is on grbl 0.9 but when I tell it to begin the programming it fails with a message saying:

“The update process could not complete. Please make sure you do not release the Z limit switch until the programming process is complete”.

Xloader just says “Uploading…” and then seems to hang.

I am, of course, holding down the z limit switch as directed the entire time from before I start the upgrade process until failure (or until I give up on waiting in the Xloader case). Doesn’t seem to help in the slightest.

So the next obvious troubleshooting step is to make sure the z limit switch is functional. It appears to be. When I open Carbide Motion 366 and initiate the homing sequence, it works as expected on all axes including Z. Likewise in UGS the homing process also works, if I then move the Z axis down enough to be able to easily reach the Z limit switch and press it manually, I see “ALARM: Hard/soft limit” in the console output and the machine becomes unresponsive until I home again or do a soft reset. So the hardware of the Z limit switch really seems to be working but holding it down appears not to be bypassing the protection put into firmware updating on the Shapeoko board…

Anyone run into this or have any bright ideas on how to proceed?

(William Adams) #177

Which board version do you have? Let them know at

(George McBay) #178

I did send an email to at the same time I posted this. Cross-posted it here in the hopes someone had run into a similar issue and had an easy fix they could share. In the past my emails to carbide3d, while eventually resolved, have usually had a fairly long turnaround on responses (understandable given the size of the company, but still frustrating when you really just want to get something resolved).

FWIW, The board is labelled “CarbideMotion v2.2” (just sent this information to as well).

(William Adams) #179

I believe we’re doing better at — can’t speak to beta.

(Jim Amos) #180

I’ve got a v2.2 CM controller and I couldn’t perform any flash operations. I ended up reflashing the bootloader.