GRBL 1.1 and Carbide Motion 4

Please send an e-mail to w/ the specifics.

To go back 0.9 GRBL 1.1 and Carbide Motion 4

Have you checked the settings to see if they are correct for your machine (e.g.$$)?

done that
going back to ver 9


Thanks will
I have a shapako 3 XL what chip is on the board
ver 2.3 pcb green colour.
dont wanna blow anything up

and I will be sending a detailed e.mail for the nice chaps at shapoko

Hi Chaps
back on ver 9 now
all working now apart from the limit switches
I have worked through will’s detailed plans and all good apart from
machine in the middle of the bed and when you try to home
hit limit switch comes up

the quest goes on

Make sure you type $22=1 at the MDI line to enable homing in GRBL.

Configuring homing switches is covered at:

I gather that CM 4 is still a work in process. I am interested in knowing if triquetra will work with CM 4. Not updating at this time, I want the “finished” product.

I have a relatively new SO3 (from the black friday sale) and I updated a few days ago and everything seems to be working fine including homing (after manually enabling homing in GRBL)… except the loss of keyboard shortcuts for jogging is really painful for me. I’m using remote desktop or the web interface as a stop-gap but it was much easier to use my wireless keyboard app on my phone. Really odd that the devs would choose to leave the X and Y axis keyboard shortcuts in place but break the shortcuts for the Z axis and selecting the step factor, hope this is an easy fix.

Many are lamenting this loss in CM4 @gmhoovler. Hopefully the Carbide Dev “to-do” list has this staged to roll into the next update. I’m holding off on CM4/GRBL 1.1 until they reincorporate this support. It’s an integral part of many folks workflow.

1 Like

I had just purchased a keypad to make things easier just prior to upgrading to CM4.:frowning:

I bought the Triquetra, and it did not work on CM 4. I was using UGS to get triquetra to work for me, then for some reason my board started freaking out, the triquetra script started going squirley doing weird things even with the same code I was running to probe my jobs. So I downloaded back to 0.9 then same issue. I am having to buy a new board for my machine. Can’t say it is CM 4 maybe a bad upload of code to the board.

If the board’s firmware is corrupt, you should be able to restore functionality by just re-flashing.

If that doesn’t work, please mention it to — worst case ought to be that you would pull the board, send it in, it would be reprogrammed and then returned — this would be caused by a corrupt bootloader. Getting around that requires a programmer or a second Arduino configured to act as one. I think there are some notes on this sort of thing at: (which arguably needs to be re-written to have two sections, one for the novice, the second for the dedicated electronics hacker).

Or, maybe I’m misunderstanding this case.

1 Like

thanks for the info, I did roll back to 0.9 but I don’t think I used that link. I know there are several places form I used one under Shapeoko forum that I downloaded the 0.9g code. It was getting confusing which one to use. I might try the link you provided GRBL code and see what I get. It was weird one minute my Triquetra was working under UGS then all of a sudden it started going crazy when I tried to run a simple probe script. That was at 1.1 then going back to 0.9g recently it still did the same. That board may need he boot loader redone.

I should have my new board I ordered here in the next day or so. If I can redo this existing board, nice to have one on hand. I would be up to sending it back to Carbide for them to test and see what really happened and see if they can learn from it.

See the video of the Triquetra in action. I was just running a simple 1/8 bit grbl code that worked many many time, then all of a sudden it started going bonkers when I ran it.

Oh yea I forgot to mention I did contact support on this specific issue.

Any idea when the update to GRBL 1.1 will be considered stable and not “bleeding edge”?

I might be wrong, but looking at the GRBL GitHub site, it looks like there are no real outstanding issues with 1.1f. I think the issues are more related to finishing Carbide Motion v4.


I am looking to roll back grbl for shapeoko3xxl and only see grbl for nomad. Is it the same?

Yes, they are the same. Don’t forget to reset your settings after you do so.


Thank you much appreciated

I have tried several times to flash, using different baud rates but when I hit the upload button my cnc makes a couple of clunking noises and then xloader just hangs. I tried holding down z axis limit switch as well but same result.
Any ideas gents?