Grbl 1.1 and Universal Gcode Sender 1.0.9

I’ve been running Carbide3D’s new build of Grbl 1.1 for a few days now. I use UGS, though, and I have a few serious bugs to work through. The primary and critical one is that UGS is no longer reporting the Work Position or Machine Position; they’re all zeroed out.

I am also trying out the nightly builds of UGS Platform which includes specific feature support for Grbl 1.1, but it has also been buggy, so I was hoping to get old reliable 1.0.9. Can anyone shed some light on this pairing?

Grbl 1.1 requires explicit support for many features, and won’t work fully with communication / control programs which were written to support 0.9 or earlier.

Thanks, @WillAdams. I seem to have stepped head first into a deeper problem trying to get my S3XXL to act like a laser cutter with Grbl 1.1. I can now no longer do anything more than connect to the CarbideMotion board. After that, all I get is error:13 in UGS 1.0.9, “error: Check Door: Safety door detected as opened and door state initiated.” in UGS Platform (which is the same as error:13 in UGS 1.0.9), and nothing happens if I try and home with Carbide Motion 4. I had no motion or homing problems prior to re-loading the settings with the dropdown menu in CM4. The best I can figure is that the CarbideMotion board thinks it’s controlling a Nomad instead of a S3XXL. It shouldn’t be paying attention to the Nomad’s safety door interlock in the first place.

My order of operations was this:

  • Reflash CM 2.4c board with the Carbide3D Grbl 1.1 updater from Grbl 0.9
  • Ran 8-10 files using UGS 1.0.9 and UGS Platform with no errors or problems related to safety doors
  • Because of some strange behavior observed during jogging, I tried loading the default Grbl settings to the controller board via CM4
  • After I did that, I was no longer able to control the S3 without errors relating to the safety door. There are also red ad green LED’s flashing on the board that were not there before.

I have been trying to use XLoader to roll back to 0.9 but it just hangs on “Uploading…,” and have also tried to re-flash 1.1 with the CarbideGrblUpdater, but that doesn’t seem to change any of the symptoms.

Finally, I’ll just mention that the LED’s do not start flashing until I connect to the board. Otherwise I just have a solid blue power light.

My suggestion would be to go back to 0.9 — if that won’t work, let us know here and we’ll help you puzzle it out.

That was my thought, as well, but Xloader just hangs on uploading. I have been unable to roll back. This is Windows 10, btw. And I tried both Mega2560 and Uno with the same result.

Another gcode sender that I like to use is Intelli-Gcode. Rodger says it’s 1.1 compatible and I’ve been using it with little trouble since I’ve upgraded to it.

Try before you buy…


Thanks for the hot tip, @UncommonDad . I’m going to give the demo a shot tonight, although I don’t see a price for it anywhere. Do you know what the cost is for the full version? Unfortunately, I’m not sure that another g-code sender is going to get me out of this error:13 pickle that I’m in, so I might have to work that out first.

@WillAdams - Is there a pinout available for the Nomad? I had had the thought last night that maybe I could add a jumper to the safety door pin(s) so I could at least get my machine moving again. Fool it into thinking I have a door and that it’s closed. Also, you can flash 0.9 back onto the board with the Arduino IDE, correct? Maybe that would be worth a shot.

1 Like

Hey John, it’s $49. He doesn’t list the price for some reason. It shows up when you try to select buy from the application menu and click the buy link.


If you want electronics information, please contact and let them know what you want to do and someone who understands this stuff should hook you up.

If your machine won’t re-flash, contact and we should be able to at least suggest why it won’t and a solution — I suspect your machine is missing, or the USB bootloader has become corrupt.

1 Like

OK, thanks, @WillAdams.

I’ve written to support, so I’ll see what they have to say. I just tried XLoader on a second computer, also running Win10, but it hung up there, too. I thought a little more about the USB bootloader being corrupt, but the C3D Grbl 1.1 Updater flashes the firmware just fine, so… Nothin’ worse than a non-operational machine. It’s like having an itch you can’t scratch. :smiley:

Update: Sheesh. To deepen the mystery, it looks like a safety interlock was only put on Nomads destined for Europe. So now not only does my S3 have an identity crisis, it has an accent!

1 Like

I tried Intelli-gcode and really liked it (bought it too) I use it with Triquetra as macros. It does have a lot of built in features that have improved my productivity. Rodger just updated the program this past week. It is worth a try.

1 Like

Yeah, I love using its built in probing function. I’ve got the Triquetra probe too and find it easier to use than Charlie’s toolbox…I like the toolbox’s other functions tho too. Can’t have too many options…lol